5

Since none of the solutions found here Silencing "Your disk is almost full" notification worked for me on Mojave, I simply disabled the deamon.

sudo mv /System/Library/PrivateFrameworks/StorageManagement.framework/Resources/diskspaced /System/Library/PrivateFrameworks/StorageManagement.framework/Resources/diskspaced.disabled

Brute force, I know, but unloading/removing/disabling using launchctl didn't work and I got annoyed.

Is there a more elegant way to turn off Apple's constant nannying alert messages?

  • I'm voting to close this question as off-topic because this is not a question and should be an answer. – Mark Dec 9 '18 at 13:21
  • I would achieve that by moving many data files to another storage medium, commonly known as backup... – Solar Mike Dec 9 '18 at 14:16
  • 1
    Close voters - There's a bona fide question here. We may not agree with the premise, but it's here. See the very last line. – Allan Dec 9 '18 at 14:42
  • 1
    Yes, there is a question if you read the entire post. I already have backups and require all files on my disk. My company disables USB storage solutions, so that is not an option either. As you can see I already referred to the other post on this topic in the first line and mentioned that none of the solutions work. – Brendan Kelly Dec 22 '18 at 3:48
  • 1
    20GB free is not "nearly filled" in my books, and yes, already moved what I can off the disk into the cloud. No you cannot yet point VMware fusion to the cloud. Yes I need VMs that are local to do my job. No USB is not an option as per above. – Brendan Kelly Jan 24 at 4:21
1

Put mac on do not disturb - this worked for me w/ Mojave

  • I mean it works...but then none of your notifications come through. – JBis Dec 18 '18 at 17:35
  • 1
    I just want to turn off the disk notification, not all. – Brendan Kelly Dec 22 '18 at 3:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .