1

This is the weirdest problem that I have ever faced. I have a MacBook Pro 15 2017 (MPTR2LL/A ?, running on MacOS 10.14.1), and I recently installed Windows using Bootcamp (dual boot) and then installed Parallels 14. This is what is happening:

  • Before I installed Windows, everything was perfect. Then I install Windows using Bootcamp (new partition and all). During the installation process, I notice that Windows was unable to connect to the internet, and hence I was unable to log in using my Microsoft account. I let it go, I figured some drivers might be missing, and I just finished the install.

  • After the installation, I boot up the Windows partition, everything works perfectly, the resolution is set automatically, and I was like great, this should work now. But nope, I connect it to my dorm room router, and it doesn't connect to the internet. It actually kills my router for 15 minutes (my university has a weird internet policy, they kill your line for 15 minutes if they detect any incorrectly configured router).

  • As this didn't work out, on the suggestion of my friend, I install Parallels 14 and boot up the Windows partition. The situation is still the same, it doesn't connect to the internet and kills my connection.

  • After my connection is restored, I try googling for a fix, but I notice that the internet doesn't work on the MacOS either. So I go to the best solution known to man: "try turning it off and on". I restart it, and the internet works on the MacOS. I boot up Windows again using Parallels and the internet stops working on both operating systems.

  • So I thought maybe it's my router (pretty irrational, since the internet doesn't work on MacOS either). So I go to the library and connect to the university wifi and try the same thing, but the situation is still the same.

So now, I've officially given up. I am pretty sure it is some checkbox that I ticked, or didn't tick, but I cannot solve this on my own. Has someone ever experienced this before, or can suggest something that I can try?

  • nice long story. what is missing is information about your WiFi settings, for OSX and for Windows. Please let us know what it is. It looks like the Windows tries to take over the Internet (settings) and fails, and OSX can not get it back until you restart. – Ruskes Dec 8 '18 at 18:22
  • Please read this and see if it helps...Use Apple Software Update to fix Wi-Fi issues in Boot Camp support.apple.com/en-us/HT207591 – Ruskes Dec 8 '18 at 18:25

This site is temporarily in read only mode and not accepting new answers.

Browse other questions tagged .