1

How do you change touchbar settings in OSX Mojave?

In previous versions of OSX, you would click 'Customize Control Strip'. enter image description here

Customize control strip option is missing in Mojave enter image description here

According to apples documentation, it should be easily done in the keyboard preferences under 'Touch Bar'. However there is no touchbar option

https://support.apple.com/guide/mac-help/touch-bar-mchlbfd5b039/mac

You can set options that change what’s shown in the Touch Bar. For example, instead of showing app buttons and the collapsed Control Strip, you can have the Touch Bar show just the expanded Control Strip or just app buttons. You can also change what happens when you press the Fn key on the keyboard.

On your Mac, choose Apple menu > System Preferences, click Keyboard, then click Keyboard.

Set options.

Touch Bar shows: Click the pop-up menu, then choose an option—App Controls, Expanded Control Strip, F1, F2, etc. Keys, or Quick Actions.

If you don’t want the Control Strip to be shown at the same time as app buttons or Quick Actions, deselect Show Control Strip.

Press Fn key to: Click the pop-up menu, then choose an option.

The options available depend on what you set for “Touch Bar shows.”

You can use the Automator app to create custom workflows for Quick Actions that are available in the Touch Bar, if you set the options for the Touch Bar to show them or added the Quick Actions button to the Touch Bar.

To always show function keys (F1, F2, etc.) in the Touch Bar for specific apps, choose Apple menu > System Preferences, click Keyboard, click Shortcuts, select Function Keys in the list on the left, then add the apps on the right.

Update

I looked at a coworkers laptop also running 10.14 Mojave and they do have a 'Customize Touch Bar' option.

enter image description here

  • Mine looks like your coworkers. You may want to update your question to be about why you specifically don't have that setting on your computer. First thing I would check is if you have anything unique about your keyboard setup (languages, external keyboard etc.), also I would click on "Change Keyboard Type..." on the bottom left, and see what that brings up. Maybe update the question with your findings as well. – JBallin Dec 9 '18 at 1:45
1

As soon as I rebooted my Mac, the problem fixed itself.

Now my keyboard preference pane looks like it should and I’m able to modify the Touch Bar.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .