7

I'm attempting to sync my iPad with my MacBook pro, but every time I plug it in I'm getting a message from iTunes, "A software update is required to connect to your iOS device." When I click "Install," I get another error message: "Can't install the software because it is not currently available from the software update server." The iPad's charging icon is also blinking off and on.

As I've been poking around the internet about this, I've gotten several answers about how this is something to do with a beta version of iOS, however currently running only the most current and stable builds of iOS and macOS (iOS 12.1.1 and macOS 10.14.2). Apparently installing xCode worked for some folks back in July/August, but I've done that to no avail...see this thread with the same problem, and a user offering the xCode solution: A software update is required to connect to your iOS device / iPhone

Any help is much appreciated!

Order of messages and subsequent error: enter image description here

enter image description here

enter image description here

  • Welcome to Ask Different. Have you ever had a beta build on this iPad or Mac? – fsb Dec 6 '18 at 18:36
  • Nope. They have always been updated with current and stable versions. – MGlaser Dec 6 '18 at 18:41
  • Any official solution to this issue? – Joshua Pinter Dec 28 '18 at 17:50
2

Just solved this issue. I was using a thunderbolt hub, and connected to that was:

  • My iPhone
  • Power Supply

I removed the power supply and connected it to another thunderbolt port and it worked. In my case, I think it had something to do with the power and the iPhone being in the same hub - maybe the power adapter was pushing too much power into the hub.. god knows, but it's fixed!

  • 1
    For me it was related to power as well. The iPad was at 34% power, and possibly a lot lower - the readings are off sometimes. After recharging it the issue no longer occurred. – jk7 Jan 29 at 18:49
1

I just got a new iPhone XR and got the same issues when I plugged it in to synch to my MacBook Air. Both devices have the latest software 10.14.2 and 12.1.1.

Before doing any Xcode downloads / installs. I tried an new cable and the isssue went away.

Try that.

  • Did this help anybody else? I'm using a third-party cable and don't have access to an Apple lightning cable. – Joshua Pinter Dec 28 '18 at 17:50
1

I was also stuck in this warning message for a while.

Try signing out of your Apple account by going to Account -> Sign out and signing back in. That solved this issue for me

  • This issue was caused by my MBP having logged out of my iCloud account (unbeknownst to me). Logging back in fixed it. Oh and I had previously tried different combinations of lightning cables and USB ports, none of which worked. It is, of course, possible that there are multiple root causes that result in this same symptom. – Peter Feb 1 at 22:02
0

Logging out of itunes did not help me. I also noted that I could not back up to iCloud. Deleting more items allowed me to install finally. Perhaps the error message is incorrect.

0

Using a shorter cable solved the problem for me.

0

After several times of failed downloads I switched the USB port used on the back of the iMac. It started downloading. Very slowly. But Activity Monitor showed data was downloading. Then it started working. But iTunes got stuck and it said it needed to download the software again. I had to force kill the process in Activity Monitor. When restarted it was OK. Then the iPad started up and I had to enter the passwords etc. It didn't work again. So pulling the plug out and putting it back in got it working again and the data sync started.

0

Solved mine - Had the same exact issues, phone kept connecting and disconnecting when i was connected to a usb port on my mac.

All i had to do was go to settings on the phone, and log on to my Apple account. No update was needed.

-1

Changed the cord and the issue stopped. Quite frustrating.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

protected by Tetsujin Feb 14 at 12:02

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.