1

I tried downloading android-studio-ide-181.5056338-mac.dmg to install it, but double clicking the .dmg does not nothing but put Android Studio 3.2.1 under the locations sidebar in the Finder. When I click that, I get the error message: enter image description here

I tried doing the same for installing Amazon Photos and the exact same thing happened.

What's going on with my Mac being unable to open .dmg files?

Mac OS 10.14.1 (18B75)

  • Mac is protecting you by hiding the Non Apple apps. – Ruskes Dec 5 '18 at 19:56
  • That's not desired behavior. Have never experienced this before. It should at least give me the option to open anyway, but it literally does nothing and gives theses confusing useless errors. – ShrewdSimian Dec 5 '18 at 20:08
  • You are right. I would say this is a bad behaviour in term of security. The error produced is of no help about the origin of the problem. I suggest you to report this on the Apple feedback server: apple.com/feedback/macos.html . – daniel Azuelos Dec 5 '18 at 23:48
2

Tell your Mac Gatekeeper, you are the Boss and responsible for your actions and decisions.

Open the Terminal app from the /Applications/Utilities/ folder and then enter the following command syntax:

sudo spctl --master-disable

Hit return and authenticate with an admin password

That should now allow you to download and install non Apple apps, by selecting it in the System Pref > Security

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .