3

I'm running some long-running CPU intensive scripts, but I've noticed that the CPU utilisation becomes 0 when the display sleeps. I've already kept the machine awake using caffeine. Is this expected behaviour?

  • what OS is it ? on what Mac ? – Ruskes Dec 5 '18 at 16:51
  • @Buscar웃 I'm on 10.13.6 and MBP 2014. – John M. Dec 6 '18 at 16:01
1

In High Sierra there is a 2 setting in System Preferences > Energy for that. Enable Prevent computer from sleeping....or/and set Display sleep to Never.

enter image description here

  • I've tried checking 'Prevent computer from sleeping...' but the process is still suspended when the display sleeps. I'll try setting Display sleep to Never. – John M. Dec 7 '18 at 5:55
  • you might have to restart for the settings to become permanent – Ruskes Dec 7 '18 at 5:58

You must log in to answer this question.

Not the answer you're looking for?Browse other questions tagged .