3

Note that there are other questions on Ask Different with similar issues, but this appears to be different to those - none of the solutions offered in the above questions solve the issue.

I'm using macOS Mojave version 10.14.1 (18B75). In the past few days, 'Desktop' has appeared in my Favourites sidebar in Finder.

enter image description here

'Remove from Sidebar' is an option if I right-click the item:

enter image description here

If I click this, the item disappears for a fraction of a second, and then reappears.

The same thing happens if I try to remove the item in the Finder Preferences:

enter image description here

And, unlike one solution offered on Ask Different, toggling my User folder in the Finder Preferences doesn't solve the issue.

How can I make Desktop disappear permanently?

9
  • 1
    Press F3 (Mission Control) and see how many desktops you have
    – Ruskes
    Commented Dec 3, 2018 at 17:59
  • Just the one... Commented Dec 5, 2018 at 18:18
  • interesting, so you can make it go away but it comes back by it self ?
    – Ruskes
    Commented Dec 5, 2018 at 19:05
  • Just for fun, add it to Dock, then remove from Finder
    – Ruskes
    Commented Dec 5, 2018 at 19:09
  • Hold the Option key and right click on Finder in the Dock. New widow shows Relaunch Finder
    – Ruskes
    Commented Dec 5, 2018 at 19:15

1 Answer 1

3
+50

Ok, I'm not going to pretend I know what's happening here but try deleting the file where that info is stored:

$HOME/Library/Application Support/com.apple.sharedfilelist/com.apple.LSSharedFileList.FavoriteItems.sfl2

I would bet that there's something corrupted in there. Delete it, log out and log back in or reboot, and try to remove it again. See if that helps.

1
  • 1
    Yep, we may not know why it happened, but this has fixed it. Thanks :) Commented Mar 31, 2019 at 21:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .