0

I was silly enough to set a bunch of video encodes running and leave my computer resulting in it running out of disk space.

On return to discover it I tried to empty the trash which would have solved the issue but due to low disk space that did not complete properly.

I ended up having to reboot the machine and the "emptying trash" dialog/process did not exit properly.

On reboot the trash appeared empty but none of the diskspace that should have freed was available.

Third reboot this time into safe mode, what freed up space was adding a new tiny file to trash (just a random screenshot) and emptying trash. That freed up the 150G I was expecting.

However, now with system appearing to run normally and the space freed as expected, I do a disk utility first aid check and the following appears.

Can someone explain what does this error mean?

I'm contemplating a restore from time machine backup. It's obvious that I could "just restore anyway to be on the safe side", but I'd like to understand a bit more if possible about what has happened if anyone can help out and offer any specific diagnosis or such. Thanks.

enter image description here

  • I now realise that "Snapshot" refers to time machine snapshot, which you can see with tmutil listlocalsnapshots /. I also did tmutil deletelocalsnapshot referencing one which that listed which had '(dataless)' following it. I did not need sudo, and the immediate result is that disk util check now passes without errors. It appears, for now, that things just might be OK, so I'll probably just make sure my tm backups keep rolling, and hold off on the restore from tm backup. I'll re-evaluate in a week I think. – mwal Dec 2 '18 at 23:53
  • Here's the link where I got the solution (I also used man tmutil) discussions.apple.com/thread/8092082 – mwal Dec 2 '18 at 23:56

You must log in to answer this question.

Browse other questions tagged .