Is it possible to disable the obnoxious green hyperlink bounding boxes in Preview (PDF)?

I do not have access to the latex. The link to the paper is here: https://arxiv.org/pdf/1806.01261.pdf.

When viewed on google there are no boxes, but when I download it for editing the pdf becomes a green swamp. I could not find any setting in Preview to disable this (on High Sierra). a sea of green

  • 1
    is that on Mojave ? Also, can we have the PDF link to crosscheck – Ruskes Dec 1 '18 at 17:12
  • I found some possibly good answers on our sister site tex.stackexchange.com/q/823 – Ruskes Dec 1 '18 at 17:49

Found a simple solution. If you print the pdf and download the print preview you will get a flattened version of your pdf.


enter image description hereThat's not a Preview thing, the boxes are written into the PDF. I see the exact same display (green or red outlines for all links) using the built-in HTML PDF viewer in Firefox, or when opening it in Adobe Acrobat Pro. The author chose this link color, apparently.

Updating answer to include a screenshot taken in Adobe Acrobat. The link in the paper is explicitly set to render with a green, visible rectangle around the text. rendering engine. The PDF renders exactly the same (with green, visible rectangle around the text) on a Windows machine running Adobe Acrobat. If it renders with green visible rectangle around the hyperlink in multiple independent PDF engines across 2 platforms, AND a PDF editing tool shows that the links are explicitly set to render with this green rectangle, it is not logical to assume that this is a macOS or Preview bug.

  • This is false. The hyperlinking is written into the PDF, but the boxes are not. Apple seems to have recently updated PDFKit so that all PDF applications I use on macOS (Preview, Skim, TeXShop) all show these ugly boxes—on documents which did not exhibit said boxes in previous versions of OS X. [Or perhaps the boxes are written into the PDF, but not all viewers display them—in which case the question is then how to reclaim the (desired) behavior where macOS doesn't display the boxes.] – Radon Rosborough Dec 30 '18 at 2:55
  • Acrobat Pro and Firefox don’t use PDFKit. I’m not convinced it’s a render error; if all PDF viewers are now showing the boxes, they must be written into the PDF itself. Whether it’s intentional or not is something to ask the article author. – dr.nixon Dec 31 '18 at 3:42
  • The built-in PDF viewer in Google Chrome doesn't show the boxes, for the exact same PDF that shows boxes in Preview et al. The fact is that until recently, all PDF viewers on macOS didn't show the boxes, and now they do. Many authors relied on the previous behavior; changing all existing PDFs is not a practical option. What is needed is an option in macOS to restore the previous behavior. – Radon Rosborough Dec 31 '18 at 15:43
  • See edited solution above. The visible green boundaries are absolutely coded into the PDF, as a "visible rectangle" in lime green. Displaying the boundaries is not a rendering engine bug. If I change to "invisible boundaries" in Acrobat, the boxes disappear. If anything, prior FAILURE to show the boundaries in Preview is a bug. Which means any recent change to PDFKit was done to remove - not to add - a rendering error. I'm not trying to be argumentative here - look at the PDF in an editor instead of a viewer. You will see the same thing I'm seeing. – dr.nixon Jan 23 at 19:47
  • Also see Buscar's link in comments above, to a thread explicitly discussing how TeX adds the green boxes unless specifically told not to. – dr.nixon Jan 23 at 19:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .