0

I have been using a midi keyboard with the third party app Playground Sessions, and it worked fine. I broke the midi cable connecting my keyboard, and since I replaced it (with the same model cable) every time I play a note on the keyboard, it sustains on the app long after I depress the key. Also, the keyboard no longer registers by the name (Yamaha) on midi devices in the software, but instead says "VIEWCON..."

The keyboard sounds fine on its own when not connected to the computer.

I've tried a second brand new cable with the same problem, so it's not that.

I've deleted and reinstalled the driver multiple times.

I've tried on a different computer, and with GarageBand. Same problem.

When I connected a sustain pedal (long after the problem arose), pressing the sustain pedal causes the computer to play a note (E above middle C, for what it's worth).

I've swapped the in/out midi connection.

Any other ideas? I'm on El Capitan on one computer and Mojave on another. No difference.

  • sounds like you broke more than just the cable – Ruskes Dec 1 '18 at 4:05
  • @Buscar웃 You may be right, but the keyboard sounds fine when not connected to the keyboard--just added that to the question. – thumbtackthief Dec 1 '18 at 15:32
  • can you provide the Cable specifications, and the Yamaha model. Also what driver did you delete. – Ruskes Dec 1 '18 at 15:48
1

According to my research of your problem (and I do not have have your set up to confirm).

Not sure what did you do to break something else aside of the cable, but following instructions might help.

Since the Yamaha is wrongly identified as VIEWCON lets hope it is just the Driver (software)

Follow the instructions here to remedy the problem.

Pay attention to the section how to remove and reinstall. (page 7)

enter image description here

|improve this answer|||||

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .