0

I have a 2015 Macbook Pro 15", and when I connect the mini DisplayPort to my external monitor, the WiFi speed drops significantly (from > 100 Mbps to < 10 Mbps). I noticed that the WiFi noise level jumps from -95 dBm to -75 dBm after I plug in the DisplayPort cable. I tried several different WiFi channels (1, 6, 11) and there is no significant difference between them, so it's some sort of broadband noise. Since the SNR is so low, the MCS index is set at 0.

The other annoying thing is, once MCS is set to 0, even after I unplug the DisplayPort cable and the noise level drops back to -95 dBm, the MCS is still stuck at 0 and my WiFi speed will not recover. Even turning WiFi off and on again won't help. But this is a secondary issue. My main problem is why display port will introduce such strong noise which kills my WiFi speed in the first place.

The cable I use is a Monoprice mini-DisplayPort to DisplayPort cable.

enter image description here


UPDATE

I got a new mini-DP to DP cable and this time the noise level dropped to the normal level of -95 dBm. However, the MCS is still at 0?? The WiFi speed increased to 20+ Mbps but still not where it should be.

enter image description here

  • did you try another cable, this one might have defective shielding, or just rap some aluminum foil around it – Ruskes Nov 30 '18 at 6:32
  • I don't have another cable at the moment. I'll try to get another from a different brand. Do you know which brand is good? I thought Monoprice was fairly reputable. – LWZ Nov 30 '18 at 6:36
  • I was going to recommend Monoprice ! are you sure it is the cable and not the device (monitor) – Ruskes Nov 30 '18 at 6:44
  • I don't know. How can I find out? When I unplug the cable the noise level instantly drops 20 dB, while the monitor is still on. – LWZ Nov 30 '18 at 6:50
  • is it distance dependent (how far is the monitor) – Ruskes Nov 30 '18 at 6:52
1

Turn off the Wi-Fi Direct function on your LG 4K monitor if it does have one (check the LG documentation) and you will be able to recover a Wi-Fi network working.

If your cable isn't a shielded one (this should be written explicitly on its packaging) or doesn't have a ferrite core , just replace it. Sooner than later you will have interferences on your image displayed and on all use of radio frequency within a few meters.

Another way to workaround this huge noise level could be to switch your MacBook Pro on a 5 GHz network = channel above or equal 40. This configuration has to be done on your equipment building your Wi-Fi network. This is your Belkin wireless router. But this won't fix the origin of the problem.

  • I can't find WiFi Direct setting on my monitor... And I don't know why my laptop will choose the 2.4GHz over the 5GHz. They have same SSID and my phone at the same location picks 5GHz with good signal strength. If I move the laptop to the same room as the router it will pick up 5GHz. – LWZ Nov 30 '18 at 22:14
  • I advise you to search within your user manual. You can get it there: lg.com/us/support/tvs# . – dan Nov 30 '18 at 23:52
  • Thanks. I checked the manual and there's no WiFi Direct. I managed to get the laptop to connect to the 5GHz this time, and the noise level is still at -90dBm when I plug in the cable. So there's no interference at 5 GHz. – LWZ Dec 1 '18 at 3:26
  • Are you sure? All modern LG monitors are advertised to be easily accessible thanks to Wi-Fi Direct. You should also see this network to be choosen from your Wi-Fi menu on your MacBook Pro. – dan Dec 1 '18 at 10:01
  • The manual is here gscs-b2c.lge.com/downloadFile?fileId=yqD5hp6LrjfGjuI37w3JsQ from my Google search the WiFi direct is for connection between phone and smart TV, not monitor. – LWZ Dec 1 '18 at 18:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .