82

I keep the "System Preferences" app icon in my dock in Mojave. I recently checked for updates, and found one, but I'm not ready to install it just yet and the red notification dot over the settings app is really bothering my obsessive-compulsive self.

To make things worse, there's no way to disable the notification for the settings app, from the settings app.

How can I banish the notification icon until I'm ready to deal with doing updates?

(Note: this a the red notification badge/dot over the System Preferences app, not the App Store one. It is also not the big textual one that will appear in the upper right corner of the screen. And, unlike all the other questions I found while searching for this, I am in Mac OS rather than iOS.)

The closest thing I found was Why is the System Preferences Dock icon showing a Badge?, which was about iCloud security problems rather than software updates. My question isn't why, but how to ignore a software update for a while.

System Preferences dock badge notification icon

85

After some unsuccessful googling, followed by loads and loads of digging and grepping through binary files, I stumbled upon a key in a .plist which, when written, appeared to make the system temporarily forget it had any updates to bother me with. Running:

defaults write com.apple.systempreferences AttentionPrefBundleIDs 0

fixed my issue for now on 10.14.1. (Apparently, you may also have to restart the dock with killall Dock, but I don't remember having to do so).

If you have automatic checking for updates turned on, this might not work for you. Not for long, anyway. In my case, on a fresh install, I went to the settings page to turn off checking for updates, at which time it checked for an update before I could close the page. After running that command again it went away once more, though. Basically, turn off automatic update checks, or it'll come right back and you'll have to run the command again.

Re-running the update checker should undo this. One might be able to find that .plist (I believe it was in /Users/[username]/Library/Preferences/com.apple.systempreferences.plist) and set the immutable bit on it/give it read only permissions to prevent it getting modified, but I have no idea what the fallout from that could be. You'd probably not be able to change any other per-user settings anymore.

12
  • 7
    Works for hiding the Catalina update that was released today. It appears that checking for updates will make it reappear, at least until you restart Dock again. Thanks for doing the hard work finding this default key!
    – CoBrA2168
    Oct 8 '19 at 0:11
  • 2
    @CoBrA2168 thanks. Really wish apple did more thorough public documentation on their OS internals!
    – Wyatt Ward
    Oct 8 '19 at 14:34
  • 3
    This also works for notifications related to iCloud
    – user35581
    Nov 14 '19 at 15:24
  • 2
    @Alex Johnson Did you disable automatic update checking in settings before running this? Not doing that would make it come back. You can also run sudo softwareupdate --ignore "macOS Catalina", which would more permanently block the notification without disabling other update checks. If you did this and wanted to update later you'd have to run sudo softwareupdate --reset-ignored though. So I'd just disable all automatic update checks in the settings application instead. It'll still check whenever you go back to that screen that way.
    – Wyatt Ward
    Apr 20 '20 at 3:47
  • 3
    Still works for Big Sur. I had a bubble pop up again for the Big Sur update. Went back into System Preferences → Software Update → Advanced… → Unchecked "Check for updates". Then ran @Wyatt8740's command above, then killall Dock, and the update bubble is gone again. Nov 13 '20 at 9:46
21

Here is what worked for me to get rid of the red notification ballon and still have access to System Preferences from the dock.

Replace the Systems Preferences icon on the dock with its Alias:

  1. Remove System Preferences icon from dock (either drag icon off dock or right-click on it and choose "Options" and then "Remove from Dock").

  2. In a Finder window navigate to the Applications folder, right-click on the Systems Preferences app and choose "Make Alias".

  3. Add the alias file to the dock by dragging it to the desired location on the dock.

The alias icon does not include the red notification bubble. The Systems Preference panel will still show the red notification on the Software Update icon (as shown in the partial screen shot image).

enter image description here

3
  • 3
    Tried Terry Richmonds suggestion but Alias still has red notification
    – nrglog
    Oct 9 '19 at 1:52
  • 4
    This solution only works by misdirection, and doesn't actually disable anything at the system level. :-) It is very clever, though. Kudos on an alternate method!
    – IconDaemon
    Oct 9 '19 at 2:44
  • 1
    Interesting idea; I'd done similar to make folders open in finder instead of opening up in that "speech bubble" thing in snow leopard, but I'd completely forgotten. I don't like the arrow icon, but it's a clever solution if you don't mind it appearing in the 'apple' top bar menu and when the settings app is opened.
    – Wyatt Ward
    Oct 10 '19 at 13:30
12
+50

I found that the killall Dock solution didn't work (anytime I restarted my computer I had to run the code in Terminal again), and the Alias solution left me wanting to really figure out how to do this!

So, with some searching, here is how I've permanently handled this issue (without the need to run code in Terminal):

  1. Open system preferences
  2. Open software update
  3. Click "advanced..." (bottom right)
  4. Unclick "check for updates"
  5. Command + Q system preferences.
  6. Turn off internet.
  7. Reopen system preferences.
  8. Reopen software update.

Ta da! No red dot.

Here are those steps in photos:

Step two (red dot!!) - Open software update: enter image description here

Step three - Click "advanced..." (bottom right): enter image description here

Step four - Unclick "check for updates": enter image description here

Step six - Turn off internet: enter image description here

Step six - Reopen software update (no red dot!): enter image description here

Step seven - Turn internet back on: enter image description here

8
  • 4
    @Wyatt8740 Just a solution that doesn't require opening Terminal at all (as was the solution offered in your OP). This alternative may be helpful for people who are hesitant or afraid of messing with Terminal. Not meant to be offensive to you in any way. Mar 10 '20 at 2:46
  • 4
    I’m going to bounty this unless there’s a better way to suppress this without the command line. Thanks everyone, great questions often need a couple answers for everyone facing this to choose their preferred method of solving it.
    – bmike
    Apr 4 '20 at 14:10
  • 2
    @bmike Definitely. Hopefully this helps generate more alternative solutions. :) Apr 5 '20 at 18:31
  • 2
    @BlunderingEcologist Ah that's right. Sometimes I forget this is the apple stack exchange and not the Unix one (where there's no real fear/intimidation of the CLI). Well, I guess it's fair.
    – Wyatt Ward
    Apr 6 '20 at 1:22
  • 2
    @Ryan Catalina is a bit of a mess. With this release Apple has made the decision to remove support for 32-bit applications (e.g. Office for Mac 2011). Apple started warning users about this with macOS Mojave (10.14), and now the cutoff is real. macOS Mojave is the last version of macOS that will run 32-bit apps. If users intentionally (or accidentally) install this new macOS version, they will lose access to their 32-bit applications. The only fix is to wipe their Mac and then reinstall the previous macOS version and all of their applications etc. Nov 16 '20 at 18:50
2

It's not the red dot itself that bugs me, it's that I'm still on Mojave, not yet ready to go to Big Sur, and don't want that reminder in my face all the time. I want syspref in the dock and running. Similarly, I always have a Terminal window open. I put the command in a file where I wanted it, named it, and updated my path. When I get the occasional red dot, I can hit the terminal window, enter "badge" and that is that. Elegant?...maybe not so much, but works for me.

#!/bin/bash  
defaults write com.apple.systempreferences AttentionPrefBundleIDs 0  
killall Dock
1
  • you could have just turned off automatic update checking and run my command and not had to run your script constantly... Sysprefs can run, just don't go to the updates section.
    – Wyatt Ward
    Aug 3 at 18:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .