2

I am following this: https://www.makeuseof.com/tag/turn-nas-windows-share-time-machine-backup/

Which basically says that you have to create a sparse disk image and put that on your external network drive and mount it.

I create the sparse image with disk utility:

enter image description here

Notice that I chose 128 bit encryption for the sparse image.

I add that to my network drive and mount it.

Once I do that I have to tell timemachine to use that disk:

sudo tmutil setdestination /Volumes/TimeMachine

That works great, when I open timemachine it is setup with that disk and I can perform backups.

However when the backup starts I get a warning that I am backing up an encrypted drive to an unencrypted disk:

enter image description here

Normally if you can find the drive on the network through the TimeMachine UI, there is a checkbox to encrypt your backups. However when using tmutil on the command line I do not believe that there is an option for that.

Is there a way I can get time machine to perform encrypted backups using this method?

If not is there a way that I can mount this external network drive in such a way that the TimeMachine UI will be able to see it on the network so I can select it as a backup drive?

You must log in to answer this question.

Browse other questions tagged .