127

When I am doing some work on my macbook pro, Mail app's main window keeps popping up in the background, it even pops up when I watch movies by interrupting full screen. This is so frustrating, I can't find out solution to this, googled and went to many discussion forums, no luck, suggestions that I found are very old and outdated. Has anyone faced similar issues or does anyone knows solution to this?

  • 2
    If you were observing for a while, when it pops up, google accounts go from offline to online. So I think that their logging-in is the reason to the popup. You could try putting them offline using mailbox menu. – anki Sep 4 '19 at 20:24
  • Sometimes, if you force quit an Application, macOS reports information about the Application to Apple so this might be an easy way to let Apple know about the bug. I think there might also be a section for comments but IDK for sure. – Todd May 6 at 13:17

10 Answers 10

46

I have the same issue: The google calendar stuff is nonsense. The notification settings suggestion doesn't work.

I've narrowed it down to the following:

I normally hit the red cross button on the viewer window once I have finished looking at my mail, this closes open viewer windows but leaves the mail app active in the dock:

So if I have mail running, but no viewer windows open, then I get a viewer window randomly popping up to the foreground a few times an hour.

If instead of hitting the red cross button, I minimise mail using the minus button, then I don't get any viewer windows randomly opening. In this scenario, the mail viewer window is minimised either on the right hand side of the dock or into the application icon itself, depending on your settings (System Preferences > Dock > "Minimize windows into application icon").

So I have changed my habits to work around this annoying bug...

| improve this answer | |
  • 4
    Now we just have to wait a few years to be allowed to minimize fullscreen windows – Andreas Jul 6 '19 at 12:15
  • 4
    or just quit the damn mail, i have an annoying and whopping 20k unreads anyway! – serdarsenay Jul 15 '19 at 23:49
  • Tried everything else, this is the only thing that works, wonder if this is on the 'roadmap' to be fixed at some point, it's been happening now for many months. – Simon L. Brazell Jul 19 '19 at 2:40
  • Tried everything else, this is the only thing that works, wonder if this is on the 'roadmap' to be fixed at some point, it's been happening now for many months. – Simon L. Brazell Jul 19 '19 at 2:40
  • 3
    I did a screen capture of this happening and it looks like it pops up because of an auth error with gmail (that quickly resolves). The error text shows up just under the search bar. I have 2FA turned on and wonder if that in combination with how frequently mail fetches happen is causing problems. I'll just hit the minus for now – y3sh Sep 6 '19 at 13:29
25

I have solved this problem by removing my Google account in Mail and making my Google Gmail address a normal (IMAP) account. Since then no more pop-ups.

| improve this answer | |
  • This is the correct answer. It's a Mail.app/GMail interaction. – vy32 Mar 29 at 17:54
  • Can you add details on exactly what you did to your answer please? My gmail account is already IMAP and this keeps happening. – Louis Lac May 12 at 11:26
15
  1. Mail > Preferences > General, uncheck:
    "Prefer opening messages in split view when in full screen."

  2. If you need real time notifications, best is to give the Mail app its own desktop in one corner. I've been doing it for several weeks and got no issues. You can also put some more background apps there: music ?

  3. ⌘-W and ⌘-Q are your friends.
    Maybe try to get in the habit of closing Mail when watching a movie? It'll save you this hassle, a little battery life, and I promise, your mail will still be there when your movie is over. :)

  4. Maybe try a different mail app? The thing is, Mail.app has been a really wonky program since time immemorial. Its one of a handful of apps that has never once got a full rewrite (along with the likes of Grapher and Activity Monitor). So I wouldn't hold your breath for a fix for these mysterious stirrings. So, if you're someone who really prefers a good desktop email client, you might want to look at a program like Unibox (super slick, ~$15, and/or available through Setapp). Outlook 2019 isn't too bad either, although it is still Microsoft Outlook, so there's "a lot there".

| improve this answer | |
  • 10
    Thanks for #1. That's a good tip. #2 is hardly a helpful snarky comment. Substitute "watching a movie" for "doing work". #3 is also not an answer to the question and in many workplaces is not a viable option. – Wesley Bland Jun 21 '19 at 14:25
  • 2
    @WesleyBland The original question specifically mentioned interruptions while watching full-screen movies, so it wasn't that snarky. – Jason Machacek Jun 27 '19 at 23:16
  • 2
    the question is how to solve this issue and not all these 3 answers; me for example, I want to understand whether some fraud service is doing it or it's just an apple's bug; besides this the mail app of apple is a great mail client! – Nikita Jul 18 '19 at 12:22
  • 1. this advice has no any connection to question asked. it just do what it means: let you open email messages in a split view (near to the main Mail window) when you use Mail app in a fullscreen mode – okliv Feb 28 at 10:56
  • 1
    What part of actually solving a bug is it to just close the app and never use it? That's not a solution. If you have a car you like, that you always drive with AC on and some quiet music, and every now and then some random really loud and annoying emergency broadcast keeps interrupting your awesome CD or cellphone music... Would you never turn your stereo on anymore? Or would you only turn it on every 5 minutes to check witch music is currently playing, then turn it off again? Or maybe even remove the stereo completely? I need emails to "ding" me when they arrive, I need the app always open. – Pierobon Jun 20 at 10:10
10

I was hoping that with Catalina the problem would be solved, instead here I am.

Looking for a solution I tried to activate the logging of the connection status (from Mail menu: Windows -> Connection Status). Examining the log when the Mail app is popping up, I found out these error messages at the exactly same time and on every occurrence of the problem (when the app doesn't pop up the error messages don't show up):

READ Oct 10 20:41:21.323 [kCFStreamSocketSecurityLevelTLSv1_2] -- host:imap.gmail.com -- port:993 -- socket:0x6000003b7de0 -- thread:0x60000322d080
5.659 NO [AUTHENTICATIONFAILED] Invalid credentials (Failure)
--
READ Oct 10 20:41:21.427 [kCFStreamSocketSecurityLevelTLSv1_2] -- host:imap.gmail.com -- port:993 -- socket:0x6000003b7de0 -- thread:0x60000322d080
6.659 BAD Invalid SASL argument. z66mb54202756wmc
--
READ Oct 10 20:41:21.732 [kCFStreamSocketSecurityLevelTLSv1_2] -- host:imap.gmail.com -- port:993 -- socket:0x6000003b7de0 -- thread:0x60000322d080
7.659 NO [AUTHENTICATIONFAILED] Invalid credentials (Failure)

(Just posting the lines containing the errors)

The error messages are present only on the log file of my Gmail account, every other mail account doesn't show any error message. So as many of you, I also think that the problem is due to the Gmail accounts.

Hope this can help to solve the problem in any meaningful way.

| improve this answer | |
9
  1. Reason

the reason seems to be this link

  1. Solution

I tried everything out. The only thing works for me is to "minimise" Mail.

  1. Trick

Because I normally close an app by shortcut command+w, It's so annoyed to minimise Mail every time.

So I added a shortcut to close Mail using command+w. World is much better then.

System Preferences -> Keyboard -> Shortcut -> App Shortcuts -> +.

(I guess you know the next already) enter image description here

| improve this answer | |
  • Best solution ever! uahuahauha, how do I give you extra points? – Pierobon Jun 20 at 9:55
7

Do you use Google Calendar? Google calendar event notification can cause Apple Mail app open.

| improve this answer | |
  • 3
    Yes. I have a bunch of gmail accounts that have Calendar enabled and I have had them on for years without a problem. The link seems like an annoying working around in which I would be left without notifications. This is not a viable option for me. – JBis Feb 14 '19 at 5:07
6

I found this answer on Apple Community website useful. It also works to my situation. I think the reason is the Mail app does not support 2-step authentication well. So don't use the Gmail portal to connect your Gmail, but generate an app password from Google website and manually set up your Gmail using the normal email portal in the Mail app. enter image description here

| improve this answer | |
3

I deal with this is by "quitting" Mail with ⌘-H. That hides mail, but keeps it active in the background. If you reopen mail, it starts up exactly the way you hid it before.

| improve this answer | |
  • Just to clarify, it is actually hiding the application, not quitting it. It would still appear in CMD+TAB strip. Emphasis on the double quotes. – anki Oct 3 '19 at 19:40
  • True, but if you close the mail app (red button), it's in the cmd tab window too. It just doesn't do anything if you select it. Plus its quicker working with hiding and cmd tab than opening apps from the dock. – Mirko Oct 6 '19 at 12:52
  • 1
    the red button closes all windows (that is what we see in File menu too), quitting is cmd Q(both quit and close are different), hiding all windows is cmd H. Re: "It just doesn't do anything" Actually it does! it brings up mail application in focus where you can use alt cmd N for a new window. – anki Oct 6 '19 at 12:55
3

My experience with Mail has been that it activates itself and windows in the background every time it has a problem connecting to one of its mail services. You can tell this by seeing the "lightning bolt" connectivity icon show up in the Mailboxes sidebar.

This user-hostile behavior seems to have no option to disable it and it doesn't seem to matter if the app is hidden or minimized. Apparently someone at Apple thinks it is so important that you know that one of your mail servers was temporarily unreachable that it requires interrupting whatever else you were working on to tell you. There may be some hidden settings in the prefs plist for Mail, but I've never taken the time to poke through it.

| improve this answer | |
-4

you need to follow this way on top menu , but first you should fix google calendar step on google account settings. then; Mail > Accounts > Google and uncheck calendar. if you have multiple google account, apply this to all

| improve this answer | |
  • 7
    When you uncheck the calendar, your don't get your calendar events anymore. Certainly this is not what the question asks. – Reyraa Jun 25 '19 at 7:41
  • But we can deactivate notifications of Google Calendar (in its own preferences online), so we don't loose the events. – leon Nov 4 '19 at 0:10
  • yes. that's right but I stopped this popping up problem in this way. Its not good idea, if someone has good idea to fix, can say here. I couldn't fix below suggestions – DrAchernar Nov 5 '19 at 10:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .