I am trying to enable the "Debug" menu in Safari 12.0.1 on Mojave 10.14.1, the command should be:

defaults write com.apple.Safari IncludeInternalDebugMenu 1

However, nothing happens.

For reference a "Debug" menu should appear in Safari in the menu bar as described for example in this blog: https://www.igeeksblog.com/how-to-enable-debug-menu-in-safari-on-mac/

Does this command still work on Safari 12? Is there a new way to show the Debug menu?

Thank you

  • 1
    Yes, it still works. Related: apple.stackexchange.com/questions/343343/…
    – Redarm
    Commented Nov 29, 2018 at 13:18
  • Fantastic! Thank you ! That's indeed the answer, can I accept it?
    – maggix
    Commented Nov 29, 2018 at 13:58
  • I’m not sure if this is considered a duplicate. I’ll post the answer again, just in case...
    – Redarm
    Commented Nov 29, 2018 at 15:08

1 Answer 1


Applications (including Terminal) do not get "full disk access" (e.g. your user files) any more in Mojave.

Try to grant Terminal access in...
System Preferences > Security & Privacy > Privacy > Full Disk Access

Unlock the system preference panel, by clicking the lock at the bottom left and filling in your password. Then either drag and drop Terminal.app onto the window, or navigate to it by clicking the plus sign (+).

Full Disk Access

Then launch Terminal and try your command again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .