2

iPad iOS 11, Recently found that Google desktop site, on both Google Chrome and Safari, does not let me select anything from the populated drop down list. When trying to make a selection in the drop down, the selection just doesn't work. It does work though in Mobile Site mode. Is anyone else seeing this problem, or could test replicate please? I think it’s caused by Google’s webpage structure forcing to use Mobile site.

3
  • Firstly, welcome to Ask Different! :) Can I ask if you've tried double-tapping on the selection? It doesn't have to be a quick double-tap, just tap once and then tap again. – Monomeeth Nov 28 '18 at 11:19
  • For what it's worth, usability of Google pages from mobile has gone downhill tremendously in recent years. The mobile interface is often dumbed-down to the point of uselessness, and some sites either refuse to open in desktop view or revert back to mobile when trying some actions (try logging in to a second account - easy on desktop, impossible or painful on mobile!) Google pushes their app ecosystem hard, and they seem to be intentionally crippling the mobile versions and iOS usability specifically to get people to install their apps. – dr.nixon Nov 30 '18 at 21:57
  • Monomeeth, Sorry missed your reply...yes tried that, doesn’t work. Hoping it may have resolved itself by now, but hasn’t. – Drat and double drat Dec 31 '18 at 10:51

You must log in to answer this question.

Browse other questions tagged .