0

While I was using my MacBook Pro, I went to setting and ironically I disabled all the finger touch option from Trackpad. Now I can't click anything just the icon is moving around. I tried to plug in another keyboard and mouse in the USB drive was showing press to continue. Sadly I can't click at all.

Anyone with the idea how to restore the option as I am having lots of difficulties.

1

First try to restart the computer.

If the keyboard still responds try to get to terminal from quick search. (cmd space normally)

in terminal you can try to change the preferences via the command "defaults" the folling command outputs the various settings.

defaults read com.apple.driver.AppleBluetoothMultitouch.trackpad

The output for me is here. 1 means active (or true), 0 means not ative (or false).

{
    Clicking = 1;
    DragLock = 0;
    Dragging = 0;
    TrackpadCornerSecondaryClick = 0;
    TrackpadFiveFingerPinchGesture = 2;
    TrackpadFourFingerHorizSwipeGesture = 2;
    TrackpadFourFingerPinchGesture = 2;
    TrackpadFourFingerVertSwipeGesture = 2;
    TrackpadHandResting = 1;
    TrackpadHorizScroll = 1;
    TrackpadMomentumScroll = 1;
    TrackpadPinch = 1;
    TrackpadRightClick = 1;
    TrackpadRotate = 1;
    TrackpadScroll = 1;
    TrackpadThreeFingerDrag = 0;
    TrackpadThreeFingerHorizSwipeGesture = 2;
    TrackpadThreeFingerTapGesture = 0;
    TrackpadThreeFingerVertSwipeGesture = 0;
    TrackpadTwoFingerDoubleTapGesture = 1;
    TrackpadTwoFingerFromRightEdgeSwipeGesture = 3;
    USBMouseStopsTrackpad = 0;
    UserPreferences = 1;
    version = 5;
}

to set any of these keys type

defaults write com.apple.driver.AppleBluetoothMultitouch.trackpad KeyFromAboveList -bool true
  • Wow, I think I love Terminal commands! – Lisa Ann Nov 27 '18 at 18:15
0

I did restarted the system keyboard does work normally and as per your above instruction went to terminal search went to defaults read com.apple.driver.AppleBluetoothMultitouch.trackpad and its showing TrackpadRightClick = 0;

and i tried making as adjustment as per above instruction which is defaults write com.apple.driver.AppleBluetoothMultitouch.trackpad KeyFromAboveList -bool true the reply i got is defaults have not been changed' -bash: -boo1: command not found Can you elaborate ???

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .