1

Hello I recently purchased iMac so I tried to set up things so that I can remove my old windows desktop away and still be able to use both Mac OS and Windows

If I shutdown from Windows, it boots up by itself in 2~3 seconds. This doesn't happen in Mac

Here's brief intro on my setup

  • iMac 2017 5k with Mojave 14.01
  • bootcamp windows 10 education 1803
  • bluetooth keyboard and logitech bluetooth mouse with unifying receiver
  • LG 27uk850 (external monitor which works just fine on both Mac and Windows)
  • Both Mac OS and Windows are installed from clean state. and have nothing much installed yet and is fully up to date

the symptom is whenever I do shutdown in Windows 10, it will shutdown but it will turn back on after 2~3 seconds

I've found bunch of solutions on the web so tried all that I could find which are:

  • disable fast boot
  • turn off hibernate
  • turn off WOL on ethernet and wifi (also tried with my router off)
  • check some registry settings about hibernating

All of those didn't have any effect.

I did find out though that if i unplug the usb c cable which is connected to the monitor, problem is solved. And interestingly if I plug the usb c hub which has hdmi, pd in, usb 3.0 port problem persists even though nothing is connected to the hub

I think this problem is narrowed down to something to do with USB PD. because the hub supports usb PD and even the monitor supports usb PD another reason is that if i leave the usb c cable (to monitor) plugged to iMac and unplug it from monitor this doesn't happen

Now that I have all this in my hand, I don't know which action to take next. I just couldn't find anything specific to my problems so now I am kind of lost here.

My question is would there be a way for me to use iMac with external monitor plugged in at all times and still be able to use both Windows and Mac OS without any issue?

ps. if I boot into windows, default boot drive defaults to Mac OS. only way to change this is to boot on to Mac and set Mac OS drive the default booting drive. is this correct behavior?

edit. to users with egpu, do you have the same problem with enclosure attached?

  • Here is how I fixed it: I ordered a usb-c to HDMI connector so that it wouldn't have USB PD and it now works like a charm! except now with dual monitor lol client goes haywire I actually have to disconnect the cable anyways. So I decided to sell iMac and move to mac mini.. – Jihwan Choi Nov 28 '18 at 12:35
1

You should be able to use both OSs with the external monitor plugged in at all times, is try restarting from the bootcamp app in the bottom/windows menu bar (the same place that discord, steam, and wifi icons are). If that doesn't work, try rebooting into target mode, and then shutting down and rebooting while pushing the option key

  • thanks for the comment. everything is alright while using it. I just have problem shutting it down after using Windows because it won't shutdown it will boot up after couple seconds – Jihwan Choi Nov 26 '18 at 6:39
  • Hmmm, how are you shutting it down? – Sam Nov 26 '18 at 6:42
  • from the start menu i press shutdown. i've tried adding shortcut to it to add some options like shutdown.exe /s /..... something but that has no effect – Jihwan Choi Nov 26 '18 at 6:43
  • Do you have bootcamp installed? If so, try to shut down via the bootcamp app – Sam Nov 26 '18 at 14:40
  • I do have it installed but there is no shutdown there is only restart in mac os and restart in target disk mode – Jihwan Choi Nov 27 '18 at 11:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .