Results in About This Mac:

macOS Mojave
Version 10.14.1
MacBook Pro (Retina, 13-inch, Early 2015)

This hardware shipped the OS version 10.10 Yosemite, if I remember correctly.

In either the Mojave update or the High Sierra update (I think it wasn't as early as by the Sierra update), VirtualBox.app stopped being runnable. I'm pretty sure this was still functioning by the time El Capitan was running.

The VirtualBox.app appears grayed out when finding it on Spotlight. When hitting it, it won't start normally as it did once upon a time, and the message is:

You can't use this version of the application "VirtualBox
.app" with this version of macOS.

You have "VirtualBox.app" 5.0.0.

[?] [OK]

I guess I'll install an up to date build of the same major version 5. It's going to be a bit painful because I should back up the virtual machine before the update, and it's big. But...

Before I do that, can I get any better reporting message of the problem? Or do you know what is happening?

The binaries in /Applications/VirtualBox.app/Contents/MacOS/ seem to be all 64 bit.

  • Have you check the messages in console app? Nov 25 '18 at 10:29
  • It seems /Applications/VirtualBox.app/Contents/MacOS/VirtualBox runs and splashes the "Oracle VM VirtualBox Manager"!
    – 146438
    Nov 25 '18 at 10:45
  • All virtual machines fail to open with exit code 1 (NS_ERROR_FAILURE (0x80004005)).
    – 146438
    Nov 25 '18 at 10:47
  • There is also a message about a missing kernel driver and/or module not installed rc=-1908. This last message seems easier to troubleshoot searching in the Internet. :)
    – 146438
    Nov 25 '18 at 10:50
  • Looks like a security issue. I have provided an answer Nov 25 '18 at 10:54

This was fixed in VirtualBox v5.2.14 (bug #17805)

Download the latest version of VirtualBox for Mojave compatability

  • 1
    I backed up my virtual machines, I installed the latest version for that same major version, and it worked nicely well right from the beginning. This is not news, or it shouldn't, but when speaking of virtual machines, better be cautious.
    – 146438
    Nov 25 '18 at 21:59
  • 1
    I backed up my virtual machines.... Music to my ears. Glad it worked out for you.
    – Allan
    Nov 26 '18 at 0:08

Go to system preference -> security & privacy -> general and check if you see the following message

enter image description here

If so, press Allow... and follow the instructions there.

  • I saw this same trouble shotting in a Medium blog, but no... there was no alert like that one.
    – 146438
    Nov 25 '18 at 16:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .