2

I recently got a MacBook Air and every time I try to download an app from the Mac App Store, a message box appears saying: We could not complete your purchase. (null) can't be installed on "Macintosh HD" because OX X version 10.12 or later is required. And I look at the Updates tab and there are no updates available. I am certain my MacBook is up to date so why can't I download anything?

Edit: My Macbook is OS X Version 10.8.5

  • Welcome to Ask Different :) What is the version of macOS installed on your MacBook Air? – Nimesh Neema Nov 24 '18 at 20:00
  • click on the Apple, top left, then on About this Mac, what does it says there – Ruskes Nov 24 '18 at 20:25
  • Since others think they have better answer, I am deleting mine. – Ruskes Nov 25 '18 at 4:17

You must log in to answer this question.

Browse other questions tagged .