0

The trackpad on my MacBook Air keeps losing its physical "click". It still works fine, and pressing the trackpad down still works, it just doesn't move.

I've tried adjusting the relevant screw two or three times and on each occasion this has worked, but after a short time the trackpad reverts to not clicking.

Short of changing out the entire trackpad, what can I try in order to fix this?

-1

The trackpad doesn’t actually move or have a physical click on any 2015 MacBook Air — it uses a haptic device to tap back at you when you touch it to simulate a click. So I guess that your Taptic Engine has failed.

  • Well, "About This Mac" is telling me it's an early 2015 13" MacBook Air, and I can see the trackpad moving -- the click has actually come back, which it tends to sometimes. My understanding is that haptic "clicks" came in on MacBook Pros in 2015, but not the Air. – Jim Nov 25 '18 at 20:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .