0

I can't write to my USB on MacBook Pro. The USB was working well on both Windows and Mac until it stopped working on Mac suddenly (it's working well on Windows though). I reformatted it as FAT32 and tried other formats too (ExFAT,...etc) but, still facing the same issue.

Under "sharing and permissions", I find "you can only read" and it is greyed out so, I can't change it.

Any ideas are welcomed as I've been stuck in this since more than 2 weeks.

  • Where did you last format it? I pretty much default to ExFAT for all USBs, and do the formatting on macOS using Disk Utility. Nearly always works unless the Windows machine is too ancient to recognize the format. Rarely if ever have issues on the Mac side of the equation... – dr.nixon Nov 27 '18 at 22:02
  • I last formatted the USB on the Mac using Disk Utility. It works well on the Windows machine without any issues at all. The issue is on the Mac only where it shows as "Read Only". I'm using High Sierra if that would help. – user311613 Nov 30 '18 at 13:50
  • That is really weird. Only time I have seen anything similar was an instance where the USB had a physical write-protect switch, and it had been accidentally bumped into the "on" position to block write attempts. Maybe try formatting the disk on Windows instead? – dr.nixon Nov 30 '18 at 21:27
1

I have seen that issue (disk being read-only on Mac and read-write on Windows) before where it was caused by a slight disk corruption.

I solved it by plugging the USB drive into a Windows PC and running scandisk to check for and correct errors on the drive. Afterwards the drive worked just fine on both Mac and Windows for reading and writing.

Note that it is important to "safely eject" the drive whenever you want to disconnect the drive from the Mac or PC. On the Mac, you'll need to press the small up-arrow besides the drive name in Finder (called unmounting). On the PC you'll need to look in the dock for the icon for safe ejecting hardware, select your drive and eject it. Another option is to power down the PC/Mac whenever you want to unplug the drive, but that is cumbersome.

If you do not safely eject the drive, you risk corrupting the drive.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .