3

I'm trying to set up a hotspot, sharing the connection from an iPhone X running iOS 12.1 with a MacBook Pro running macOS Mojave. The hotspot is working fine and other devices can connect to it and use the internet, but although the MacBook connects to the hotspot OK, browsers don't work.

The MacBook can ping the DNS server set by the phone's DHCP, and other servers, but lookup fails (dig, nslookup or the network utility tool), and all browsers report that there is no internet connection.

I've tried going through the answers to this question but nothing seems to have made any difference.

Both devices have been restarted multiple times, and I've reset the phone's network settings.

3

After hours of experimenting, and a long and pointless call to my network operator, I finally managed to fix it... by deleting the phone from the list of known wifi networks on the MacBook, and reconnecting. Same SSID, same password, now working fine.

I recently switched SIM, moving to a new carrier. With the old carrier, the MacBook could use the phone's hotspot with no problem. I don't know what info gets stored for a wifi connection (I'd assumed just SSID and credentials) but presumably there's more to it...

| improve this answer | |
  • Not working for me. It randomly works and stops working sometimes cant connect for days (sometimes connects but no internet). No such problems using hotspot on a windows machine. What the heck apple??? – trainoasis Apr 16 at 9:43
1

I got the same issue and solved it differently.

In my MacBook, I had the DNS server setup to point to Google's public DNS IP (8.8.8.8 / 8.8.4.4), I simply deleted those registers and left the default. It worked for me, hope it works for you.

| improve this answer | |
0

Hi Personally i fixed this problem by deactivating my second sim card on my phone. It is a dual sim phone so I deactivated the card that I wasn't using and it worked. i hope it helps someone.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .