0

I used this questions's answer to install Linux(I installed Mint, however, not Ubuntu) and followed along.

I do believe I didn't follow the answer properly, as I still have a placeholder partition unused, but Linux installed and works perfectly. I did have to use the diskutil resizevolume disk0s2 140G 3 jhfs+ part1 800M jhfs+ part2 200M jhfs+ part3 200 command differently as I am on High Sierra, and I have APFS containers. I gave 4GB for Linux Swap

Linux Mint works perfectly, but when trying to boot into Windows via the option boot menu(on startup), the built-in boot manager freezes. If Windows is set to the default startup drive, I get a blank screen.

The Bootcamp partition has next to no important information, I can format/reinstall it if necessary.

The following is my diskutil list output. BaseQi is a exFAT 64GB SD Card.

/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *251.0 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk1         120.0 GB   disk0s2
   3:                 Linux Swap                         3.9 GB     disk0s3
   4:           Linux Filesystem                         64.1 GB    disk0s4
   5:                  Apple_HFS part3                   200.0 MB   disk0s5
   6:       Microsoft Basic Data BOOTCAMP                61.8 GB    disk0s6
   7:                        EFI NO NAME                 500.2 MB   disk0s7

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +120.0 GB   disk1
                                 Physical Store disk0s2
   1:                APFS Volume macOS                   15.4 GB    disk1s1
   2:                APFS Volume Preboot                 65.3 MB    disk1s2
   3:                APFS Volume Recovery                1.0 GB     disk1s3
   4:                APFS Volume VM                      1.1 GB     disk1s4

/dev/disk2 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *64.0 GB    disk2
   1:               Windows_NTFS BaseQi                  64.0 GB    disk2s1

Below is the output for diskutil info disk0s6

    Device Identifier:        disk0s6
   Device Node:              /dev/disk0s6
   Whole:                    No
   Part of Whole:            disk0

   Volume Name:              BOOTCAMP
   Mounted:                  Yes
   Mount Point:              /Volumes/BOOTCAMP

   Partition Type:           Microsoft Basic Data
   File System Personality:  NTFS
   Type (Bundle):            ntfs
   Name (User Visible):      Windows NT File System (NTFS)

   OS Can Be Installed:      No
   Media Type:               Generic
   Protocol:                 PCI
   SMART Status:             Verified
   Volume UUID:              163F7FD4-C9A1-4E82-BA76-8FDA822A9A52
   Disk / Partition UUID:    0721D35A-134A-4C99-B221-43CDD77F19B4
   Partition Offset:         189210296320 Bytes (369551360 512-Byte-Device-Blocks)

   Disk Size:                61.8 GB (61789437952 Bytes) (exactly 120682496 512-Byte-Units)
   Device Block Size:        512 Bytes

   Volume Total Space:       61.8 GB (61789433856 Bytes) (exactly 120682488 512-Byte-Units)
   Volume Used Space:        14.8 GB (14825717760 Bytes) (exactly 28956480 512-Byte-Units) (24.0%)
   Volume Free Space:        47.0 GB (46963716096 Bytes) (exactly 91726008 512-Byte-Units) (76.0%)
   Allocation Block Size:    4096 Bytes

   Read-Only Media:          No
   Read-Only Volume:         Yes

   Device Location:          Internal
   Removable Media:          Fixed

   Solid State:              Yes
   Hardware AES Support:     No
1

Try sudo reboot disk0s6, or try rebooting into the recovery partition and running that command from there

  • Doesn't seem to work; Just get a a blank screen – PiAhoy Nov 24 '18 at 5:46
  • I'm guessing that this only happens while trying to boot up from the windows drive? – Sam Nov 24 '18 at 5:47
  • Could you please post what shows up when you type diskutil info disk0s6 – Sam Nov 24 '18 at 5:48
  • updated original post – PiAhoy Nov 24 '18 at 6:24
  • Yes, it only happens for the Windows drive; Linux and macOS work fine – PiAhoy Nov 24 '18 at 6:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .