1

I just bought Sony XAV-AX200 to use with my iPhone 7 plus in a 2007 Volkswagen Golf (Rabbit).

Now it seams that CarPlay can’t deal with my 50 000 song iCloud music library.

  • It takes 5 minutes to load the playlists
  • It takes another 5 minutes to start playing one, being unresponsive during that time
  • Once it finally starts playing a track as soon as I click ‘next’, it jams again and takes minutes to change the track

My analytics data section if full of ‘music.cpu_resource’ log entries where it says my cpu usage is around 80% over 180 seconds. Also there are standard music crash logs. And there are about 10 ‘stacks+music’ logs from a single session. All of them say ‘reason: scene update watchdog transgression: com.apple.music exhausted real (wall clock) time allowance of 10.00 seconds…..’

All the other apps on CarPlay like podcasts, maps and such work flawlessly but not ‘Music’

I am using an official Apple cable, the latest iOS 12.1, and the Sony is updated with the latest firmware.

I’ve tried most things I know from my experience with apple products:

  • reset all settings
  • restore as new
  • forget car (in carplay settings)
  • change cable

None of this fixed the problem. As soon as the icloud music library is switched on, CarPlay is in permanent beachball mode.

The only way to use it successfully is to switch off icloud music library. Then it works fine. But that’s obviously not a solution.

So I'm wondering what else I should do, or whether CarPlay can even handle 50'000 tracks. Any help appreciated!

  • This sounds more like a fault with the Sony than the iPhone. I have zero issues with my Pioneer CarPlay. Check if Sony have a firmware update - there's often one released just after a major iOS update. If you rely on your CarPlay system you may need to wait each year for that update before updating your iOS. – Tetsujin Nov 24 '18 at 6:18
  • I assume that your basic question is "How can I get CarPlay to work with my 50'000 songs iCloud library", but maybe I got that wrong. Can you shorten your question to focus on the actual problem? I understand your frustration, but the amount of detail makes it very hard to understand what this is all about. – nohillside Nov 24 '18 at 9:24
  • Thanks i edited it down and posed a single direct question. Hopefully its ok now. By the way the sony is updated with the latest firmware. – ktimamue Nov 24 '18 at 13:36
  • @nohillside hi I'm new here, not sure why my question still has (on hold) in the title, even though it was edited down three times? – ktimamue Nov 26 '18 at 13:51

You must log in to answer this question.

Browse other questions tagged .