My OSX Lion MacBook Pro suddenly seems to be unable to connect to any website via HTTPS. HTTP works fine, but HTTPS seems to just time out. Using netcat:

Mithril:~ mitch$ nc google.com 80
HTTP/1.0 302 Found
Location: http://www.google.ca/

But if I try the same thing on port 443, the request just seems to sit there forever. Trying to access any HTTPS website with Chrome gets me a message that the server took too long to respond. Safari seems to wait forever, but never get anything back. I'm also seeing some SSL errors in the Console:

11-12-21 11:47:59.621 AM [0x0-0xc4cc4c].com.google.Chrome: [62652:24579:633336744818573:ERROR:ssl_client_socket_nss.cc(1536)] handshake with server www.google.com:443 failed; NSS error code -5938, net_error -107
11-12-21 12:13:14.404 PM [0x0-0x18c08bf].com.adiumX.adiumX: cdsa: SSLHandshake failed with error -9806 (connection closed via error)

A quick Google search reveals that I don't seem to be the only one with this problem, but I can't access half the results because discusssions.apple.com requires HTTPS. The ones I can access have been entirely unhelpful.

I don't have any parental controls turned on, and other devices on the same network have no trouble connecting via HTTPS. What's going on?


Have you tried rebooting? Sometimes it's a Keychain problem. Try opening the Keychain app, and see if it hangs. If it is so, repair permission with Disk Utility and then reboot. It worked for me (happened twice on my MBA).

  • 1
    Looks like that was it exactly. Thanks! I'm confused, though: why does a keychain problem prevent me from using HTTPS? Dec 21 '11 at 21:07
  • 3
    Keychain is used, amongst other things, to manage SSL certificates and this functionality is used by some browsers on the Mac, including Safari and Chrome. Dec 21 '11 at 21:12

This sounds like a firewall issue. Do you have Little Snitch or another firewall control application installed on your mac? Have you checked the firewall settings in the System Preferences security pane?

  • 1
    Gio solved it, but I had the same thought as you. I have nothing installed besides the built in firewall, but I do have that turned on. I tried turning it off, but it didn't fix the problem, so I turned it back on. Dec 21 '11 at 21:08

Is there a firewall somewhere on the network you are using that is blocking port 443?

Perhaps the business whose wifi or ethernet you are using has a firewall, or a misconfigured or spyware infested router somewhere.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .