0

Whenever I try to upgrade my macbook with updates which require a system restart, it will begin the update then freeze on the screen with an apple logo and partially filled progress bar with the text "restarting".

System Info:

  • MacBook Pro (13-inch, 2016, Four Thunderbolt 3 Ports)
  • 2.9 GHz Intel Core i5
  • 8 GB 2133 MHz LPDDR3

  1. This began when I was running macOS 10.13.4 and attempted to upgrade to mojave (without installing 10.13.6 first). The same issue as described above happened so I powered the system off and restarted it.

  2. The update was not installed but it booted up fine and worked normally so I tried again, this time leaving it on overnight but the same thing happened.

  3. This time I tried to install the 10.13.6 update before mojave but got the same results when installing 10.13.6. Upon reboot the system was still at 10.13.4

  4. I tried installing the 10.13.6 combo update, same thing happened

  5. I tried resetting my PRAM with Command + Option + P + R but that didnt change anything

  6. I booted into recovery mode and ran first aid on my disk

  7. I booted into recovery mode and reinstalled the macOS. This succeeded and set me at 10.13.6, hooray.

  8. I opened the app store and tried to install the security update before moving on to mojave, just in case. System rebooted, began install, then froze on the "restarting" step.

I am under the impression there is an error during the install which also prevents the reboot sequence but I don't know how to track it down. Does anyone have insight into what is happening here?

  • start in safe mode and use fsck to inspect your disk – Ruskes Nov 22 '18 at 4:13
  • I gave that a shot but it came up "the volume appears to be OK". – n33kos Nov 22 '18 at 5:53
  • sorry, I forgot to say, you have to run fsck at least 5 times, Apple recommends 10 times. Also do you have USB disk with OSX to start from, or do you have a Time machine back up ? – Ruskes Nov 22 '18 at 5:56
  • Interesting, I can give that a try on my next update. It looks like I found a workaround for now. Thanks for the help! – n33kos Nov 22 '18 at 6:41
0

I ended up trying to install the updates from safe mode and that worked. It doesn't solve the issue but is an acceptable workaround for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .