I installed a lot of OSS packages when I got my new MacBook. After many updates and 2 OS upgrades XCode command line tools has REALLY gored itself. IT thinks it is installed. But everything I try to do says CLT is NOT installed. I have attempted with GREAT prejudice to delete XCode and reinstall. Mostly all I have done is lose the source code for my website. But CLT is still not usable.

I am now to the point of ready to reinstall 10.14. I do have a time machine backup but have never tried to use it to recover an entire machine before.

Will this really work? I am pretty stuck right now as Ruby but if I’m going to have to start from scratch in setting up I’ll just do without.

Opinions on bare metal reinstall?


Yes, it should really work!

However the best way to be sure of any backup is to always have multiple backups, so in this case a Time Machine backup and a drive clone using SuperDuper or Carbon Copy Cloner would be advisable.

|improve this answer|||||
  • My biggest concern, well that is losing my data. But the next biggest concern is that TM restores the messed up /Library stuff and/or NOT restores the /Applications stuff. – Terry Nov 22 '18 at 0:53
  • If you’ve not configured Time Machine through System Preferences then it should do what you want as you can select which parts of the backup to restore. – unknowndomain Nov 22 '18 at 9:14
  • However there are no guaranteees on a backup so using CCC or Super Duper will ensure a second recovery which is just a clone that can be recovered. – unknowndomain Nov 22 '18 at 9:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .