1

I have a bad problem. I shrunk my APFS volume from 850 GB to 750 GB so that I can expand my NTFS Boot Camp Volume from 150 GB to 250 GB. After shrinking everything worked fine.

Then I started Boot Camp and tried to expand the system partition with the free space of 100 GB with some third party programs in Windows. That was for sure what destroyed my APFS container. Afterwards, when I try to start macOS again the boot selector with the Option key pressed, it only shows me the Boot Camp partition.

I connected the MB via hard drive mode to my other MacBook and can see this:

/dev/disk5 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk5
   1:                        EFI EFI                     314.6 MB   disk5s1
   2:           Windows Recovery                         750.0 GB   disk5s2
   3:           Windows Recovery                         200.0 MB   disk5s3
   4:       Microsoft Basic Data BOOTCAMP                148.3 GB   disk5s4
   5:           Windows Recovery                         939.5 MB   disk5s5

Nothing to read from APFS container or other stuff. Is there a way to recover it or to rebuild the APFS container without deleting the data on disk5s2?

If not, is there an easy way to get the data from disk5s2? Thats all I need… but I cannot mount it with mount_apfs /dev/disk5s2 myfoldertomount. How can I get access to this partition?

Here are also some information but I do not know if this will work for me since my APFS container is not shown, and I have no idea where to start and how the size gets defined: APFS partition inaccessible, container missing

Here the GPT list

sudo gpt -r show /dev/disk5
Password:
      start       size  index  contents
          0          1         PMBR
          1          1         Pri GPT header
          2          4         Pri GPT table
          6      76800      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
      76806        250         
      77056  183105468      2  GPT part - DE94BBA4-06D1-4D40-A16A-BFD50179D6AC
  183182524   24584961         
  207767485      48829      3  GPT part - DE94BBA4-06D1-4D40-A16A-BFD50179D6AC
  207816314      24454         
  207840768   36205785      4  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7
  244046553         39         
  244046592     229376      5  GPT part - DE94BBA4-06D1-4D40-A16A-BFD50179D6AC
  244275968        292         
  244276260          4         Sec GPT table
  244276264          1         Sec GPT header

What can I do? Is there any chance to get my data from the partition if I cannot rebuild the APFS container? The Windows partition is not important.

Update:

Here is a partition definition:

disk5s2 -> my main macOS APFS disk
disk5s3 -> HFS+ macOS Boot wrapper (to boot into macOS from Bootcamp since bootcamp cannot boot into APFS)
disk5s4 -> Bootcamp
disk5s5 -> For sure the macOS Recovery partition

Update 2:

Now I am scanning my APFS partition with M3 Data Recovery and it seems wo work – it lists my folders. After finishing the scan I try to backup the whole data on an external storage. How will I proceed after that? Fresh install of macOS and copy / overwrite the files from backup disk via external Mac?

You must log in to answer this question.

Browse other questions tagged .