3

I have an iPad (2018) 9.7-inch. I've recorded a video using the screen recorder.

When I play the video on the iPad I hear a sound.

When I import it to iMovie I don't hear any sound.

Even when I play the video in the sidebar I can hear the sound, but when it is in the timeline the audio is no present and I can't hear anything when playing it.

Using the latest OS version.

2
  • Maybe upload the video to drive and share it here? It's hard to say why unless we can see the file. You could try audacity (audacityteam.org) and see if you can download the audio and resync it with the video in iMovie? Nov 19, 2018 at 16:58
  • Simple solution that worked for me: Export the video to iMovie two times, first as a video and the second time save the video file as an audio only. Then import the audio file to iMovie.
    – MManke
    Jun 2, 2021 at 21:28

5 Answers 5

2

If your iMovie project appears to be missing audio tracks when you play, import, or export a project, try these steps first:

  1. Make sure the audio track has not been muted in the timeline.

  2. See if the volume in iMovie is set to its lowest, if this is the case, set the volume slider to maximum.

  3. Make sure the computer's audio is not muted.

  4. Quit and reopen iMovie, then check the clip to see if it now plays with audio.

  5. Quit and reopen iMovie, then reimport the footage. Play the newly imported footage and see if you now have audio.

  6. Check /Library/QuickTime/ and ~/Library/QuickTime/ for any third-party plugins. Remove them if present, log out, and log back in. Check to see if the issue persists. If not, check with the manufacturer of the disabled plugin to see if an update is available. Note: The tilde (~) represents your Home directory.

  7. Check to see if any of the video clips you have imported are in the MPEG-1 format. MPEG-1 clips will lose audio when you export them as part of your iMovie project.

SOURCE:

1

This has happened to me many times in the past and all the methods I came across don't seem to work. But I have a solution: screen record the recording, what I mean by that is open up Photos and screen record (like usual) the video you wish to use in iMovie, so you double screen record. It can be a bit tedious but it’s the only way you’re going to get audio in iMovie with a screen recorded video.

1
  • Screen record is a good idea to capture the video. Worked for me - quality is bad of course.
    – Dennis G
    Aug 12, 2019 at 10:35
0

When you open the screen recorder from the control center, force touch it (or long press for iPad I guess) and you will see an option to turn on/off the microphone. There might be your problem of why you don't have audio in the first place.

0

That sounds like a problem I've had with iMovie now and then with clips from various sources. VLC and Quicktime play the clips with sound, but an import to iMovie fails to get any sound.

In my case this Apple discussion answer helped. Look for an obsolete A52Codec.component installed in /Library/Audio/Plug-Ins/Components. Mine was from 2011...

After just moving it to the trash and restarting iMovie, the clips imported with sound.

0

similar case happened to me. recorded movie using snap camera on the new Mac laptop. Movie played in Quicktime and VLC, even Apple Photos. But could not get sound when drag to timeline on iMovie maker.

Answer was in apple forum:

"iMovie needs Mp4/H. 264/AAC. AAC stands for Advanced Audio Codec, and if your movie contains some other audio codec that might cause the audio not to play."

I did open VLC File > Convert/Stream option and drag Snap Camera movie over there. Then search export advance options to find AAC and check box.

Resulting export movie has sound in iMovie.

Reminiscent of 10 years ago when every application has it's own format and codec cause of copyright and patent wars.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .