My Time Machine is going for a year quite strong, but I recently noticed it is not including new directories in its backup. Basically new directories are being excluded by rule or error and I'd like some help figuring out which.

  1. It still does its normal backup. The system log files says:

    Dec 21 19:35:59 leosbook com.apple.backupd[2218]: Starting standard backup
    Dec 21 19:35:59 leosbook com.apple.backupd[2218]: Backing up to: /Volumes/Wisdom/Backups.backupdb
    Dec 21 19:36:02 leosbook com.apple.backupd[2218]: 2.28 GB required (including padding), 319.50 GB available
    Dec 21 19:36:04 leosbook com.apple.backupd[2218]: [...]
    Dec 21 19:36:07 leosbook com.apple.backupd[2218]: Backup completed successfully.
  2. The newly created directory is not excluded. Checking via tmutil reveals in Terminal:

    > tmutil isexcluded "/Users/bongu/Pictures/Import/Eye-Fi/NewDir"
    +    /Users/bongu/Pictures/Import/Eye-Fi/NewDir
  3. However the new directory NewDir never gets backed up. The directory is not part of the latest backup:

    > ls /Volumes/Wisdom/Backups.backupdb/leosbook/latest/book/Users/bongu/Pictures/Import/Eye-Fi/NewDir
    ls: /Volumes/[...]: no such file or directory

How does this possibly happen? And any idea how can I resolve it?

  • Are you sure the path in step 3 is correct? Does ls /Volumes/Wisdom/Backups.backupdb/leosbook/latest/book/Users/bongu/Pictures/Import/Eye-Fi produce a valid result?
    – nohillside
    Dec 21, 2011 at 18:26
  • Yes, ls /Volumes/Wisdom/Backups.backupdb/leosbook/latest/book/Users/bongu/Pictures/Impor‌t/Eye-Fi exists and ists all thensub folders until the 13 Dec 2011 - new directories don't get backed up. The same is true for new folders under ~/Desktop.
    – halloleo
    Dec 21, 2011 at 19:53
  • what is the output of tmutil isexcluded *
    – geoO
    Dec 30, 2012 at 13:25
  • @geoO Cannot check anymore. I have recreated the machine later for other reasons.
    – halloleo
    Dec 30, 2012 at 23:32
  • I think this question is now too specific to be still on any real use. Is there any way to "close" it?
    – halloleo
    Dec 30, 2012 at 23:33

1 Answer 1


In your System Preferences << Time Machine you can tell Time Machine which files to skip. Maybe you listed the directory in this list?

  • I Chcked: No, it is not listed there. (tmutil isexcluded should tell me that as well.)
    – halloleo
    Dec 21, 2011 at 19:56

Not the answer you're looking for? Browse other questions tagged .