1

UPDATE: After observing this for a day or two, I can see that the idleTime is set to 5 minutes within System Preferences while defaults -currentHost read com.apple.screensaver idleTime still returns 1200.


The options to change the delay time within System Preferences is grayed out so I couldn't change it.

So I tried setting it with defaults.

defaults -currentHost write com.apple.screensaver idleTime -int 300

After running that command, I'll get this.

$ defaults -currentHost read com.apple.screensaver idleTime
300

However, once I go back to the screen saver settings in System Preferences, the delay goes back to 20 minutes and I get this.

$ defaults -currentHost read com.apple.screensaver idleTime
1200

The global default is set to 300.

$ defaults read com.apple.screensaver idleTime
300

I've also tried deleting the whole com.apple.screensaver domain and then go back to screen saver section in System Preferences, and I see 20 minutes and 1200 again.

I have a profiles in place where the screen saver idleTime is set to 300 but I have no idea why it's getting set to 1200.

This is on Mojave 10.14.1 (18B75).

  • Is your Mac managed by an organization? (i.e. your work place or similar) – jksoegaard Nov 19 '18 at 8:09
  • Not sure but very likely as I don't see it happening when I turn off my wifi. – josephting Nov 19 '18 at 8:11
  • How can you not know if your Mac is managed? - Where have you got it from? – jksoegaard Nov 19 '18 at 8:12
  • From my colleague. Even the person who handed it over to me didn't know what's going on and that's beyond me. – josephting Nov 19 '18 at 8:15

You must log in to answer this question.

Browse other questions tagged .