1

It used to be (still is on my High Sierra MacBook Pro) all I needed to do was untick "Calls from iPhone" in macOS FaceTime app prefs:

screenshot

But now (on my Mojave MacBook Air) this seems to do nothing. All incoming phone calls ring on my iPhone and launch and ring on FaceTime on MacBook. Even when my iPhone is in airplane mode.

I'd rather not (because I'd still like to be able to place outgoing calls—and it's not necessary on my older machine), but I also tried disabling "Cellular / Calls on Other Devices / Allow Calls on [Mojave MBA]" (and disabling the entire "Allow Calls on Other Devices", not just the MBA), yet this didn't stop the calls either.

And I've tried rebooting both MacBook and iPhone. And logging out/in of iCloud.

Apple tech support had me reset PRAM, but this did nothing. Anyone else having this trouble?

  • Turn it off on the iPhone side as well. – John Keates Nov 17 '18 at 2:35
  • I tried disabling it on the phone too. – jtheletter Nov 17 '18 at 2:37
  • In that case, you have run into a bug ;-) if you disable it both ways you should at least have a base case where nothing reacts to calls. – John Keates Nov 17 '18 at 8:16
-1

Try System Preferences -> Phone -> Calls on Other Devices -> turn it off

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .