I am not able to set the touch id, may be after some minor update to High Sierra. Before that everything was working fine.

I tried reseting the password for KeyChain Login and KeyChain Local items, however nothing is helping.

Keep on getting following error message.

enter image description here

4 Answers 4


This is a Keychain error and you probably need to rebuild it. These steps should fix it.

  1. Open Finder.
  2. Hold the Option key and on the menu click Go.
  3. Click on Library to open that in Finder.
  4. Drag the Keychain folder to the trash.
  5. Restart your machine.

You will have to re-enter all your passwords again but it should fix the Touch ID.

  • that resolved my issue. Commented Nov 16, 2018 at 22:54
  • if you don't mind can you look at my other question regrading mac. apple.stackexchange.com/questions/342884/… Commented Nov 17, 2018 at 16:09
  • Did you try the answer already provided on that other question?
    – fsb
    Commented Nov 17, 2018 at 16:18
  • yes, I have tried all the things, nothing is working so far. Commented Nov 17, 2018 at 16:20
  • Not working for me as well Commented Oct 3, 2019 at 10:53

What solved it for me was a restart. After the restart it requested me to enter the old password to 'update the password' for the keychain

I've been able to register a new fingerprint and to login using it ever since


With macOS Monterey, in addition to fsb steps:

  1. Open Finder.
  2. Hold the Opt key and on the menu click Go.
  3. Click on Library to open that in Finder.
  4. Open Keychain folder.
  5. Remove all login.keychain-db, user.kb, and keychain-2.db files (mostly the ones recently modified).
  6. Restart your machine.

With these steps, I was able to register a new fingerprint without losing all my previously saved login/passwords.


The accepted answer didn't seem to work for me at first, but then later it did. Here are some other things I did, in case anyone else encounters the same issue. I'll start with what I think were more likely the case.

  • I tend not to delete things. I renamed the Keychains directory to Keychains.bak. Maybe the system was still able to find this directory.

  • I went to Keychain Access > Preferences > Reset My Default Keychains. It was a little wonky, like not letting me change the password to the login keychain (despite its instructions to do so), but after this step and following the accepted solution (deleting the Keychains directory), things worked for me.

  • Before any of that I tried updating each of the keychain passwords in Keychain Access. I was surprised to find that the current password on the Local Items keychain was a password from a very old system that was on High Sierra. I had just restored a Mojave backup onto a Catalina system, but from the same drive that had a backup of that High Sierra system, so maybe some keychains got carried over that way.

  • I had csrutil disable'ed in recovery mode to allow CDock to make changes to the system and forgot to enable it until later.

Again, I don't think the latter ones were relevant, but posting everything just in case.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .