Short of killing all notifications, is there a way to stop "Updates Available" notifications from showing up, for app and system updates?

  • I already have "Automatically keep my Mac up to date" unchecked in Sys Prefs > Software Update
  • Everything in "Advanced..." there is unchecked
  • App Store > Prefs > Automatic Updates is unchecked

To head off any frame challenges, yes, I do perform regular manual updates, but when it doesn't interrupt my work. No, I will not tolerate automatic updates, and it doesn't matter why. Maybe I need a stable setup for development, video rendering, or I just don't like to be bothered with notifications about something that may require a restart, shutdown of critical apps, or any interruption to my work flow.

  • 1
    There doesn't seem to be an option for settings, sys prefs, or app store in notifications.
    – JWBH
    Nov 16, 2018 at 19:24
  • 2
    System updates now have their own place to live in sys prefs in Mojave. Still, I haven't found a way to stop notification coming from either Software Update or the App Store.
    – JWBH
    Nov 16, 2018 at 23:54
  • 3
    Mojave is nagging me every day about updating, but I would rather just focus on work and update in a week. There's no option to say "Remind me in a week." I hoped to stop the prompts by disabling automatic updates and downloads. Some update files are already downloaded though. Can I delete the 2.8GB of files and download them again later? Nope. Not even with sudo. "Operation not permitted". Not only does Apple nag me daily but they force me to keep files I don't want. It's like I don't own my computer and am just leasing it from Apple so they will bother me when it's convenient for them.
    – Kyle Tolle
    Dec 28, 2018 at 17:24
  • 6
    I have submitted a bug report for this issue (and I do believe it should be categorized as a bug not a 'suggestion') using Apple's Feedback Assistant and I encourage everyone here to do the same. If you'd like to include in your feedback a recommendation for how Apple could fix this issue, I think suggesting that they include App Store in the Notifications System Preference would be best.
    – Bri Bri
    Jul 7, 2019 at 15:34
  • 4
    @GuyGizmo Great idea. Here is a link to that feedbackassistant.apple.com and, and here is a template to use for your description gist.github.com/jordanglassman/a4915130d84f3e3d4638b5212d6edfa9
    – jordanpg
    Jul 18, 2019 at 12:52

4 Answers 4


If you want to disable updates for specific apps, you can use softwareupdate --ignore.

Do all the following in Terminal

Start with

softwareupdate -l

to list all available updates,

defaults read /Library/Preferences/com.apple.SoftwareUpdate.plist

to find the Identifier of the app you want to ignore, and then

softwareupdate --ignore 'Identifier'

to ignore the update. Should disappear from Software Updates in System Preferences immediately.

  • When I run the list command it only shows a Mojave update, not any app updates. Same with the identifier plist, it doesn't show any apps, just "macOS 10.14.6 Update". Is this supposed to show app updates as well? Am I missing something?
    – JWBH
    Oct 3, 2019 at 0:04


After hours on the phone with Apple's techs, the answer is simply that there currently isn't a way to silence notifications. They have various workarounds, like uninstalling any apps that might have updates or silencing all notifications, but all of them have undesirable side effects, unfortunately.

  • AppleCare support will never tell you about solutions that aren't officially supported. If there is a way to do it by digging around in your system's settings through Terminal and tinkering with things, don't expect to find out from them. (Because even though that solution may be great for you, your less savvy grandma will try the same thing, get some crucial step wrong, and render her Mac unusable...then blame Apple) It's sad, but just the way it is.
    – Mentalist
    Oct 21, 2019 at 0:29
  • True enough, but I suppose I should add that this includes the outside research I have been doing, as well as the other suggested solutions that this question has generated.
    – JWBH
    Oct 23, 2019 at 0:45

I just found this workaround:

  • Backup and remove /Library/Bundles/OSXNotification.bundle
  • run softwareupdate --ignore macOSInstallerNotification_GM in a terminal


  • I'm already in Mojave, that is I'm running 10.14.1. Does this solution work for other updates as well (minor OS security updates, App Store updates)?
    – JWBH
    Dec 5, 2018 at 19:52
  • This is only applies to the specific case of upgrading the OS itself. The OP is referring to notifications that cannot be disabled after upgrading to Mojave.
    – jordanpg
    Dec 11, 2018 at 13:57
  • @JWBH Sorry, I misread the question.
    – Pascal
    Jan 6, 2019 at 13:35
  1. I'm pretty sure turning Do Not Disturb for the Notification Center would do the trick?

  2. After doing a sudo defaults read com.apple.SoftwareUpdate, and changing the values of AutomaticCheckEnabled and/or CriticalUpdateInstall as necessary, you could always sudo defaults write com.apple.SoftwareUpdate CatalogURL -string ''. You'd never get an update notification again. Nor, of course, an update, but...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .