1

Every time I boot the mac I get a black screen, I can hear the chime but that's it, nothing comes on the display even when having an external display connected. In recovery mode it works, i get display.

  • tried NVRAM SMC resets

  • tried First Aid on the disk and permissions repair

  • tried deleting and recreating kernel cache

  • tried booting in single user mode or verbrose mode and both give me a black screen.

  • tried reinstalling the OS which worked just fine UNTIL I join the laptop to the domain (using Casper/JAMF) and reboot it goes back to the black screen issue

  • tried fsck_apfs

  • Booting into recovery, unlike single user, gives you a completely different boot image. As a test, try installing macOS on an external USB drive (a 16 or 32GB is flash is fine) and then boot from that. If the problem goes away, it's your install and you should do a clean install on your SSD (format and install). – Allan Nov 16 '18 at 17:56
  • I did a clean install twice. It boots fine after but when i get to the part where i join the laptop to the domain(corporate laptop) and have to reboot i get the black screen all over again. – Adrian Sultu Nov 16 '18 at 18:30
  • Just to clarify...if you don't join it to a domain (assuming AD) does it work as it is supposed to? When you reboot (again, not joined to the domain) does the screen work correctly? – Allan Nov 16 '18 at 18:42
  • Allan, i haven't tried that yet. But why would that part break the OS? – Adrian Sultu Nov 16 '18 at 19:34
  • 1
    Buscar, desktoppicture.db? I have to specify also that when booting i hear the chime but the screen is black, no apple logo and no mouse cursor, nothing. – Adrian Sultu Nov 16 '18 at 19:35
1

If I understand your problem right ... it only happens after you join Mac to the domain using Casper/JAMF !

Try following.. hold option on boot and manually select the boot drive again while holding control to set it as default

  • I'll try that on monday. The laptops work fine until the join to domain script runs and reboots. We replicated this one four different Macs, all have the same behavior. Something in the new image/scrip breaks the OS. I am just trying to figure out what or a way for me to get some logs and find out where it fails but since the screen is always black and can't get Verbose mode i don't know how i can see logs. – Adrian Sultu Nov 17 '18 at 0:26
  • This is the last command the script ran before it rebooted and the screen went black. Executing Policy Configure Client Login Restart Running script Jamf - Kill Self Service... Script exit code: 0 Script result: Running Recon... Retrieving inventory preferences from casper.corporation-name.com:8443... Locating accounts... Locating package receipts... Locating software updates... Locating plugins... Locating printers... Searching path: /Applications Blessing i386 macOS System on /... Creating Reboot Script... – Adrian Sultu Nov 17 '18 at 0:27
0

Found this:

  1. turn off the computer

  2. hit the power button and immediately after hit the Option, Command, P, R all at the same time.

  3. the computer will shut down again

  4. once you hear the chime again let all buttons go and the computer should start up.

  • The OP said in his very first point that he reset the NVRAM and it had no effect. – Allan Nov 16 '18 at 17:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .