13

When I re-open Safari on my Mac Mini, it keeps opening the same tabs that were open before it was quit (or before the Mac OS X was switched off). The result is that it takes too much time to be operative, especially when I restart my Mac.

In the preference panel, the "Restore windows when quitting and re-opening apps" option is already disabled, but Safari keeps opening the tabs open in the last session. I checked also in my MacBook, which is running Mac OS X 10.7.2, and that option doesn't change the Safari's behavior I describe in this question.

screenshot

Is there any way to force it not to open all the tabs? I looked at its preferences, but I have not found anything that could help me. Is there any other way to disable this feature?

2 Answers 2

14

Quit it with ⌥⌘Q or run in the Terminal

defaults write com.apple.Safari NSQuitAlwaysKeepsWindows -bool false
8
  • 2
    It works perfectly. Now Safari opens faster, and I can access the site I want without to wait at least 2 minutes. Thank you.
    – apaderno
    Dec 20, 2011 at 22:33
  • You could also hold shift while opening Safari (it doesn't work when apps are opened with Spotlight or Alfred though) or uncheck Restore windows when quitting and reopening apps in the General preference pane.
    – Lri
    Dec 20, 2011 at 22:35
  • 1
    What is "the Terminal" ? You guys said type this into the terminal. What do you mean by Terminal? What is The Terminal?
    – user118422
    Mar 17, 2015 at 0:25
  • 1
    Macintosh HD/Applications/Utilities/Terminal.app
    – IconDaemon
    Mar 17, 2015 at 0:50
  • 1
    @jaepage The difference is that in the case of my answer you can still save state when quitting if you explicitly say so (by keyboard shortcut or via the menu), while in case of the other answer you can't.
    – Gio
    Nov 17, 2016 at 14:18
11

This behavior is the resume feature.

Disable using Terminal

If you only want to disable resume for safari, type this in the terminal:

defaults write com.apple.safari ApplePersistenceIgnoreState YES

If you want to set the resume feature again, simply write NO using the same syntax.

Disable using TinkerTool

This application gives you access to additional preference settings and allows to activate hidden features in the operating system.

enter image description here

2
  • TinkerTool is basically doing all those commands for you; it's doing the same job as the terminal command, just with a UI
    – frumbert
    Dec 5, 2016 at 8:19
  • I can't believe Apple is hiding this behaviour. Well I can believe it and hate it. Thanks for the right command. Mar 5, 2018 at 20:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .