7

Update (2019): The issue still persits even in macOS Mojave, tried everything I could find, nothing seems to solve the issue as of yet!

Problem:

com.apple.hiservices-xpcservice hangs repeatedly ever since I upgraded to macOS Mojave 10.14.1. Now,everytime the process hangs it is indicated by red colored fonts in the Activity Monitor. Due to the frequent hangs my system slows down and it's barely usable due to extremely slow performance.

What I have done so far:

I have already Googled it (The Process) and also contacted Apple regarding the usage of this process and the reason behind it's frequent hick-ups. Alas! they couldn't help much. So, I terminated the process.

Temporary Solution:

As soon as I terminated the process (com.apple.hiservices-xpcservice) my mac started running fast once again.

But, whenever I restart the system or leave the mac idle for a few minutes and then if I start using it once again! out of no where, the process (com.apple.hiservices-xpcservice), shows up once again in the activity monitor resulting in slow performance issues along with hangs and freezes across macOS.

System Info:

Model

iMac (27-inch, Mid 2014)

Processor

3.5GHz quad-core Intel Core i5 processor (Turbo Boost up to 3.9GHz) Configurable to 4.0GHz quad-core Intel Core i7 (Turbo Boost up to 4.4GHz).

Memory

8GB (two 4GB) of 1600MHz DDR3 memory; four SO-DIMM slots, user accessible Configurable to 16GB or 32GB.

Storage

1TB Fusion Drive

Screenshot Of The Process com.apple.hiservices-xpcservice

enter image description here enter image description here

  • 2
    since it is user specific, try logging in as different user to test – Ruskes Nov 15 '18 at 5:52
  • @Buscar웃 Indeed it's a user specific issue, I booted into macOS via an external drive and this one had a fresh installation of macOS, it was not showing up this process i.e it wasn't hanging. Btw, I forgot to mention that I used OnyX Version 3.5.2 Beta to change a few Misc./Parameters within the effected version of macOS Mojave installed on my main internal drive. – Sayan Nov 15 '18 at 6:03
  • so you know now what the problem is and how to fix it – Ruskes Nov 15 '18 at 6:15
  • Nope it isn't fixed yet I meant to say that I used OnyX on the main installation to change some miscellaneous parameters, I thought the info might be helpful, I still have the same issue with my main installation of macOS the fresh installation doesn't seems to have any issue but it's on my external drive which can't be used on a daily basis so I still don't know the usage behind the process and why is it hanging! – Sayan Nov 15 '18 at 6:23
  • are you willing to restore the OS X installation ? or is your OnyX modifications important to you. – Ruskes Nov 15 '18 at 6:42
1

Had the problem too.

Tried to disable SIP, then remove execution rights on com.apple.hiservices-xpcservice, reboot after re-enabling SIP.

Result : Safari keeps crashing, each time it opens so it seems to be linked to apple apps.

Giving back execution rights on the service repaired Safari ..

Except killing it when it becomes unresponsive, I don't see any other solution

-1

I didn't try to disable this com.apple.hiservices, I just skipped from my computer. Problem solved. It didn't come back. However, there are some minor differences in some sites, nothing to be worried about.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • 2
    What do you mean by “I just skipped from my computer?” It’s not clear how this answers the question – Allan Feb 27 at 12:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .