1

I have a UGREEN USB 3.0 Switch. It has 4 USB A sockets on one side and 2 on the other. Its point is to share the 4 things plugged in on one side with 2 computers. I've been using it with a 2014 Macbook Pro and a 2017 Razer Blade sharing a keyboard, mouse, and USB ethernet adaptor for the last 3 months.

Today I got a late 2018 Macbook Air. I tried connecting it to the same switch but it's not working and so I'm wondering where the issue is. It could be

  1. Bad cables. I'm using USB C to USB A cables. I've used these cables for other things in the past. I tried 2 3 different cables. An Anker Cable, a TacMad cable, and a Elecom USB3-AC15 USB 3.1 cable. All 3 cables work fine for other USB devices

  2. Wrong cables? Maybe there is more than one kind of USB-C to USB-A cable?

  3. Bad Switch. The switch works but maybe something is incompatible?

  4. This isn't supposed to work. I have no idea but maybe there is something about USB-C that makes it just not suppose to work

  5. ???

To add to that I have a VANMASS 9-in-1 USB HUB. If I plug that between the switch and the macbook air everything works. In other words

[2014 MBP]<---------USB-A-USB-A-cable--------->[USB Switch]<->[Mouse] works

[2018 MBA]<---------USB-C-USB-A-cable--------->[USB Switch]<->[Mouse] doesn't work

[2018 MBA]<->[USB Hub]<---USB-A-USB-A-cable--->[USB Switch]<->[Mouse] works

Note that this is both without and with external power to the switch. Without power the switch doesn't light up (it does with the MBP and Razer). With power it does light up and pressing the button on the switch switches the LED indicator on top of the switch but the MacBook Air still doesn't see the mouse and keyboard without the hub in between

I'd like to not need the hub. It seems like I should be able to connect the Macbook Air directly to the switch just like I was doing with the Macbook Pro

Any idea what the issue is?

  • your USB Switch is not powered, the HUB is – Ruskes Nov 14 '18 at 6:31
  • I added power to the switch. No difference. – gman Nov 14 '18 at 7:48

You must log in to answer this question.

Browse other questions tagged .