2

I recently needed to restart my dock in the terminal via killall Dock as I have done many times before. However, after doing so, the dock did not restart and my wallpaper is black:

enter image description here

This is very worrying as, despite multiple restarts and a host of other attempted solutions, I have been unable to resolve the issue. I have also looked in Activity Monitor for the Dock process but I have been shown nothing when searching for it:

enter image description here

This leads me to believe that the process has not restarted. My question is: How can I restart the Dock process to fix this issue?

Thank you in advance for any help, this is a very worrying issue for me as it has greatly limited the functionality of my Mac.

Kind regards, Rocco

P.S. this was the first time I tried killing the dock with that command in OSX Mojave which may be the cause of the problem. Maybe it is an issue with Mojave as I have never experienced this with any previous OSs

EDIT:

This was the exact, full command I ran before the problem occurred: sqlite3 /$HOME/Library/Application\ Support/Dock/desktoppicture.db "update data set value = '~/Desktop/wallpaper.png'" && killall Dock

  • What happens if you open System/Library/CoreServices/Dock.app? You can navigate there in Finder or run in terminal: "open /System/Library/CoreServices/Dock.app/" – Wowfunhappy Nov 12 '18 at 20:32
  • Also, this behavior is definitely not standard in Mojave. – Wowfunhappy Nov 12 '18 at 20:33
  • run it again defaults delete com.apple.dock; killall Dock – Ruskes Nov 12 '18 at 20:35
  • @Wowfunhappy That did nothing at all unfortunately – Rocco Nov 12 '18 at 20:37
  • 1
    That is what I was going to recommend, but had to get something to eat first :) .... The problem was not the Dock, but the corrupted desktoppicture.db as you found out. – Ruskes Nov 12 '18 at 21:06
2

tl;dr Run: killall System\ Preferences > /dev/null 2>&1 && rm ~/Library/Application\ Support/Dock/desktoppicture.db && killall Dock

For anyone who may experience this issue in the future, my issue was with the file located at ~/Library/Application\ Support/Dock/desktoppicture.db.

After doing some googling, I cam across the following two threads, here and here. Both of which suggest removing the desktoppicture.db with rm ~/Library/Application\ Support/Dock/desktoppicture.db && killall Dock which solved the issue for me. You can read in more detail about the issue and proposed solution on the second of the two linked threads above

  • 1
    well done....... – Ruskes Nov 12 '18 at 21:25
-4

you can just restart your mac and then for me google chrome stopped the restart and the dock was reset so just restart cuz for me nothing worked, hand gestures, f keys, even using ctrl and arrows i had to use spotlight search to open stuff so ya j restart youll be fine

  • Welcome to Ask Different. This answer is very difficult to understand and is at risk of being deleted. Can you please edit it to add the proper grammar, punctuation, and formatting so we can better understand your answer? – fsb Feb 15 at 20:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .