1

I have a MacBookPro 13'' mid 2012, 2.9 GHz, which I have given to my partner, as I bought a second-hand MacBook Pro 2015 (beginning of 2015, 3.1 Ghz Intel core i7)

Before giving the MBP mid 2012 to my partner, I have made a copy of its hard disk (with OS Sierra), to an external SSD. Then I formatted the MBP mid 2012, made a fresh install and then upgraded it to Mojave. I have booted the MBP mid 2012 from the external SSD (restarting and pressing alt/option) and worked with it without problems. I have booted again the MBP Mid 2012 fro the external SSD (the external SSD has OS Sierra) even after having formatted the laptop and having installed Mojave in it.

Few days later I have finally received my "new" MBP 13'' Retina (beginning of 2015, 3.1 Ghz Intel core i7). It comes with OS 10.11.6 EL Capitán. I tried to boot from the external SSD (which has Sierra) in which I have copied the HD of my old MBP mid 2012 and... I does not boot. I just get the Mac sound at the beginning, but then the screen stays black. No symbol of "prohibited", nothing. Just black screen.

I presume that the system which is installed in the SSD does not recognize the hardware and wants to boot with the hardware it was installed previously (the hardware of the MBP Mid 2012...)

Any idea about how I can solve this? I have an entire series of applications in the SSD that I need to use.

Something: I am not a Mac expert, therefore I am possibly not able to understand too technical explanations.

Thank you very much in advance.

Emiliano

  • I would first upgrade the new Mac to at least Sierra. Next, I would use the Migration Assistant to see if the applications and personal data can be ported from the external drive to the new Mac. This should leave the external drive unchanged. – David Anderson Nov 11 '18 at 22:31
1

First perhaps boot in verbose mode to see what is causing it not to boot. If it is hardware incompatibility like missing driver (which can happen if the install has continuously been upgraded and so not managed to get the drivers for other Macs) then the following non-destructive steps (assuming you don't care about what is currently on the 2015's internal SSD) should fix it:

  1. On the 2012 Mac download Sierra and make a bootable installer on at least an 8GB USB drive.
  2. Boot the 2015 using the installer USB and use Disk Utility (from the menu bar) to clone the external SSD on to the internal SSD (be very careful to get this direction correct).
  3. Disconnect the external SSD to keep it safe.
  4. Quit Disk Utility and run the Sierra installer over the top of the current un-bootable installation.

That should add in all the necessary drivers for the new Macs and it should work again. It's perfectly fine to reinstall macOS it won't delete any applications or data. Good luck!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .