I've upgraded my MacBook Pro (15-inch 2016 model) to Mojave two weeks ago, and since then I've noticed that the overall performance of the OS has deteriorated, most of times when I open Spotlight search I see the "Indexing" progress bar showing up.

I've switched off Siri and most of the notifications but things are not getting better.

Is there anything to do to resolve this issue?

  • Have Activity Monitor running in the background for a few hours, then check the "Energy" tab. It will show which applications are using the most resources. Energy is a good proxy for for a mix of all types of resources (CPU,disk,graphics). You can also check the "disk" tab. – MattW. Nov 12 '18 at 23:45
  • @MattW thank, it was Spotlight that was consuming the most energy due to indexing, I started indexing all over again to resolve the issue, please check the answer below for more details – Mina Samy Nov 14 '18 at 10:25

OK, here's how I solved the issue, I hope this will be useful for anybody with similar issues: I've done some search and found that I needed somehow to fix the indexing files used by spotlight, there are some sudo commands you can use to delete the old index and start all over again, I didn't follow that, I did the following:

  • Open System Preferences -> Spotlight
  • Click on Privacy tab.
  • Open A finder window, navigate to the top most level, drag and drop the "Macintosh HD" icon to the spotlight excluded items in the privacy tab, that way Spotlight will not perform any indexing for the entire hard disk.
  • Then click on the "Macintosh HD" item in the list and click the minus sign button to remove it, this way Spotlight will start indexing from scratch and hopefully succeeds.
  • Did the problem recur after that? A few weeks ago, I did exactly what you described in your answer, but my MacBook Pro started indexing again yesterday morning and seems to be hanging at about 80% again. Has the same happened to you? – coreuter Mar 13 '19 at 8:01
  • 1
    @coreuter not really, it could be that you have a specific directory that gets modified frequently (files added/deleted) that may be causing the indexing to happen all the time – Mina Samy Mar 13 '19 at 12:55

As sort of an addendum/alternative approach to Mina's accepted answer:

I was able to get Spotlight working "as fast as I type" again by excluding every directory that wasn't the Applications folder inside the MacintoshHD drive (which is honestly really all I ever need Spotlight for anyway)

Now Spotlight is blazing fast again (i.e. like it used to be on the old Macbooks).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .