1

I've tried to list past TM backups while running in a tmux session, but the solution described in this question doesn't seem to work on macOS Mojave any longer:

root@nomi ~> tmutil listbackups
The operation could not be completed because tmutil could not access
private application data on the backup disk. Use the Privacy tab
in the Security and Privacy preference pane to add Terminal to the
list of applications which can access Application Data.

I tried to grant Terminal access to my data:

enter image description here

but it doesn't work. So how do I list/delete my old backups in Mojave if I run the shell in tmux?

1

You must run the command inside Terminal without any ancestor other than the program itself: that is no screen or tmux or any other terminal helper.

Otherwise the calling program will be the helper and not Terminal itself, and you will need to add that helper to the Privacy settings of MacOS.


EDIT: add pstree info

This happens, at least for tmux, because it spawns another process wich is not a child of iTerm/Terminal. With pstree I see the following:

-+= 00001 root /sbin/launchd
...
 | |-+= 12748 maxxer /Applications/iTerm.app/Contents/MacOS/iTerm2 --server login -fp maxxer
 | | \-+= 12749 root login -fp maxxer
 | |   \-+= 12750 maxxer -zsh
 | |     \--= 14144 maxxer tmux
...
 |-+= 14146 maxxer tmux
 | \-+= 14147 maxxer -zsh
 |   \--= 14170 root top
 |--= 14212 maxxer /System/Library/Frameworks/CoreServices.framework/Frameworks/Metadata.framework/Versions/A/Support/mdworker_shared -s mdworker -c MDSImporterWorker -m com.apple.mdworker.shared

PID 14144 is tmux launched in iTerm2, while 14146 is the actual tmux program running top in the first shell

0

I came across this error when trying to execute…

/usr/bin/tmutil latestbackup

via Apple Remote Desktop (ARD) on my iMac to iMac Mojave Clients.

And found that adding… ARDAgent.app (from /System/Library/CoreServices/RemoteManagement/)

to Full Disk Access (under Security and Privacy > Privacy) on the Client Target iMac – got it to work.

In a similar fashion the presence of SSHD in …. Security and Privacy > Privacy Tab > Full Disk Access will allow the command to be run via SSH from my iMac to a Client iMac. (SSHD will be there if you’ve enabled SSH in Sharing)

Interestingly on the client iMac itself, executing … /usr/bin/tmutil latestbackup won’t work unless Terminal is added to Privacy. But the same command executed from my iMac to target iMac via SSH or ARD will work, even if Terminal isn’t added to Privacy of the Client iMac. (So long as ARDAgent and SSHD are added to Privacy on the Client)

So it looks like you can run tmutil ‘under the auspices’ of ARDAgent or SSHD without having to add Terminal to Privacy

I’m sure all that can be explained in Terms of Caller and Helper etc (and I’m grateful to the above answer in solving my issue).

Incidentally – if you follow this thread: https://macscripter.net/viewtopic.php?id=46620

A similar case where adding osascript to Privacy sorted out the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .