1

I am currently stuck at the login screen, unable to login--each attempt just takes me back to the login screen.

This started with trying to update to OS X Mojave (from High Sierra), due to the constant message popping up urging me to upgrade. So, I finally decided to do so.

During the update, I got a kernel panic that was stuck in an infinite loop due to install error -69854.

So, I decided to try to reinstall Mojave booting to disk utility, but after 30 minutes of install, I got the same error.

Then, I reinstalled OS X Yosemite via disk utility (original OS version that came with the iMac). That seemed to go fine until I tried to log in. At the login screen, I typed in my password correctly, and it looked like it was starting to log me in, then the screen went black and immediately went back to the login screen.

I booted in safe mode and got the same behavior--looked like it was logging in, but then went black and back to login screen.

*Note that I tried an incorrect password as well, just to ensure I was typing it correctly. When typing an incorrect password, it stays on the login screen. So I know it's not the password.

I did repair permissions in Disk Utility, which completed successfully.

Then I tried doing a repair disk, but that failed with "unable to unmount volume for repair."

I rebooted again and tried to login again, but same issue.

I reset NVRAM, just in case, but same issue.

I rebooted in safe mode, but same issue.

I'm on an iMac that is a late 2013 model. No issues prior to trying to upgrade to OS X Mojave.

Any other thoughts/steps?

I'm currently creating a bootable Mojave disk to see if I have any better luck, but I'm not optimistic.

  • lets hope you made a back up before this. Interrupting a installation then installing another os x over it leads to many unknown problems. Most probably you have to wipe your disk and do a "clean install" – Ruskes Nov 11 '18 at 4:07
  • Did not do a backup. Guess I will have learned my lesson if this is the case. The fact that the installation of Yosemite worked makes me believe that my data is still there (could be wrong). So, now I'm trying to reinstall High Sierra from a full OS bootable USB. – thephatp Nov 11 '18 at 4:11
  • good luck with that – Ruskes Nov 11 '18 at 4:44
  • Reinstalling from a High Sierra bootable USB worked. I have no idea why, but it worked. WHEW! – thephatp Nov 12 '18 at 1:33
  • congrats .......now make a back up ! – Ruskes Nov 12 '18 at 1:34

You must log in to answer this question.

Browse other questions tagged .