2

I'm having odd behaviour with my Homepod. It feels like a bug. It has internet (plays music fine) and is definitely on the same wifi network as my iPhone and my other mac computer (I've verified this in my router admin area, and it is not on a guest network or anything that might have network isolation). It shows up fine in the 'home' app of my iPhone. However it randomly disappears as an airplay option (from any other device), and if I try and a do something that requires my iPhone like add a reminder I get the 'Before I can help with Personal Requests, the iOS device associated with this HomePod needs to be on the same Wi-Fi network.' message.

Note I'm on the latest firmware and iOS as of today (12.x)

3
  • how crowded is your network ? (many other WiFi on same channel). Try using different channel on your router. – Ruskes Nov 10 '18 at 17:18
  • Try restarting the router – user310476 Nov 16 '18 at 16:13
  • Restarting the router works but only temporarily. – Peter Nov 18 '18 at 0:31
4

Went to Apple today This is a fix it worked for me

  1. The phone you use needs to be on the same wifi frequency 2.4Ghz or 5Ghz

  2. Set the frequency in the router settings to restrict devices to only one frequency not set to dynamic which allows alternation depending on circumstances

  3. you can check which devices are connected to the frequency's in connected devices in router settings

I found that my devices such as phones connected to 2.4G when a few rooms away form my router but connected to 5G when close to the room with the router

because my Home pods stay in the same place they connected to the same WIFI frequency's all the time

if your home pod is on 5G and then your phone switches to 2.4G the Home pod does not work as predicted

KC

3
  • Interesting, this is the first idea I've seen that has potential merit. Thanks. Odd that homepod needs to be on same frequency and not just the the same network - that seems like a very odd architecture bound to cause very hard to track down problems. I've changed my router to explicitly have an SSID for each frequency. I'll report back on how it goes after some trial days – Peter Nov 18 '18 at 0:29
  • 1
    I'm marking this as accepted now. Since having the HomePod on the same band as other devices for the last number of days, I haven't seen the bad behavior. – Peter Nov 22 '18 at 17:55
  • 1
    This answer about WiFi frequencies proved to be the root cause of problems I had getting my iPhones to play on HomePods. My ASUS RT-AC5300 router has a “Smart Connect” option which changes which frequency devices use. That was causing AirPlay connections to drop, or fail to start. This is what the Apple Home app labels as “it does not support peer-to-peer connections.” Turning off Smart Connect stabilized frequency use and solved my problem. – Ryan Nov 29 '20 at 23:24
0

Your explanation of what is the fix is wrong. Although the easiest way to operate your HomePod is to let it be on the same WiFi. The frequency the WiFi is on nor the network the HomePod is on has nothing to do with operation/functionality of the HomePod.

For a simple setup:
https://support.apple.com/en-us/HT208241
Your phone and your HomePod should be on the same network. WiFi has nothing to do with it. WiFi is just the transport. Following the simple setup process will end up with your HomePod and your phone being on the same network and the same Wifi SSID.

For an advanced setup:
There is no link for advanced setup since Apple only recommends the simple method.
Requirements: I use the below method in my home. It allows for securing your IOT network without putting your users on the same network as your IOT. Your user devices will talk to the hubs on your IOT network and your hubs will talk to your IOT devices.

  • Allow mDNS UDP port 5353 destination 224.0.0.251 between the IOT network and the user network
  • Put your phone on the WiFi SSID(IOT) that will connect you to the network you want your HomePod to be on.
  • Perform the simple setup steps from this link https://support.apple.com/en-us/HT208241
  • On the WiFi SSID(User) network you must put a MAC address block of the HomePod. This will prevent the HomePod from jumping to the WiFi SSID(User) network.
  • Attach your phone to the WiFi SSID(User)

If you are using HomeKit and are adding accessories you will need to remember to place your phone on the WiFi SSID(IOT) network to add the accessory. Once added you can switch back to the WiFi SSID(User) network.

I would also suggest that you set the WiFi SSID(IOT) network to not auto-join on your phone so that you stay on the WiFi(User) network until needed.

I have all IOT devices, HomePods, Apple TVs and Airplay amplifiers on the IOT network. With the above setup, you can still remote control your Apple TV with your iPhones Apple remote app or HomeKit remote function Airplaying music and video will also work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .