My company has a Mac Mini that we use for iOS builds. Occasionally, one of us needs to log in to it via remote access (from a Windows PC) to update the build tools.

However, ever since updating the OS to the latest MacOS Mojave, most of the time we cannot log in remotely. On any VNC client (I use VNC Viewer but have tested this with UltraVNC as well). As soon as one of us establishes a connection to the Mac, it just shows the login screen with the username and account picture, no password prompt or buttons of any kind, and a loading spinner that just spins forever:

remote access screen is stuck with this loading spinner

I've found that I can "fix" this by physically accessing the machine and logging out of the account, but of course this is painful and impractical.

Is this just a mojave bug? Are there any ways to break out of this loop? I should mention that this didn't seem to be an issue before the mojave update.


7 Answers 7


Remote login should be allowed (System Preferences -> Sharing -> Remote login).

  1. Connect via ssh: ssh user@host
  2. Run sudo pkill loginwindow
  3. Connect using VNC as usual
  • 1
    This is the one you need when you don't have physical access to the computer but do have SSH access.
    – ChrisN
    Commented Sep 24, 2019 at 4:19
  • 2
    Very rude solution, but works. It will be more good if something like loginwindow reset was posiible.
    – basil
    Commented Dec 8, 2019 at 13:33
  • 1
    Does this terminate any processes running in any GUI login sessions?
    – kccricket
    Commented Dec 26, 2019 at 23:16
  • Thanks!. This is only a temporary fix, because the problem will come back. But it is a great tip for being able to login right now, and worry about a better fix later.
    – mivk
    Commented May 5, 2020 at 16:37
  • 2
    @kccricket : Yes, this will logout any user who might be actually using the machine. So indeed, it's a very rude last-resort only workaround.
    – mivk
    Commented May 19, 2020 at 16:30

This appears to be a bug in MacOS Mojave's VNC implementation. Thankfully, I have found a workaround.

In the settings app, select Sharing. Then select "Screen Sharing" on the left and click on the "Computer Settings..." button. Screen Sharing settings window

In the dialog that pops up, check "Anyone may request permission to control screen" and un-check "VNC viewers may control screen with password: _____". Computer Settings dialog with first option checked and second option unchecked

It removes 1 layer of security, so I would not recommend this if your mac has any public ports configured. It still uses MacOS's authentication for accounts, so as long as you have good passwords on all your user accounts it still may be reasonably secure. Hope this helps anyone looking for a workaround for this.

  • 3
    I unchecked both of the boxes in "Computer Settings" and then changed the "Allow access for:" to "Only these users:" and added the users I wanted to use. That seemed to work for me. I also updated macOS same day, so that might be it too. Commented Dec 14, 2018 at 16:41
  • @Brandon I am facing the same problem and tried "just updating" - however this seem to be not enough as the problem persists.
    – Robert
    Commented Jan 1, 2019 at 13:58
  • 1
    This works though you'll have to use RealVNC instead. With TightVNC it claims there's no compatible security methods available.
    – Adambean
    Commented Feb 20, 2019 at 11:14
  • 1
    @BrandonRader Yeah, this kind of approach looks way better than allowing anyone to request permission, IMO. Thanks for the tip, this helped me a lot! By the way, I have experienced this on High Sierra, maybe even earlier macOS versions, and still having this on latest 10.14.6 Mojave, so this is definitely not a matter of system update... And yes, I'm using RealVNC for a few years now, just because TightVNC was crashing many times a day and totally drove me crazy.
    – RAM237
    Commented Aug 23, 2019 at 14:02
  • Did not work until I rebooted the Mac. Then it seemed to not work again until another reboot. I could never get this to work consistently.
    – John81
    Commented Sep 16, 2019 at 12:45

My workaround was to run this command in order to completely prevent the login screen from appearing for VNC connections.

(Depending on your security needs, you may want to avoid this approach.)

sudo defaults write /Library/Preferences/com.apple.RemoteManagement VNCAlwaysStartOnConsole -bool true
  • Man, you awesome! Grate!
    – basil
    Commented Dec 8, 2019 at 13:35
  • This logged me in. Had used the pkill answer before but was not happy with killing all my processes. This is much friendlier. Commented May 17, 2020 at 0:33
  • This works, and doesn't kickout the logged-in user like the sudo pkill loginwindow workaround. In the screen sharing preferences, I have both preferences checked: "Anyone may request permission to control screen" + "VNC viewers may control screen with password: ...". So I still get asked for the VNC password, but skip the additional login screen and get directly to the real current screen.
    – mivk
    Commented May 19, 2020 at 19:04

So apparently this is strictly a VNC issue. I usually use Tight VNC to connect to my Mac at home from work and I was getting the same spinning login. This time I tried to use the Screen Sharing feature built into OSX (by going to Command+K and entering vnc://ipaddress:port) and it prompted for my laptop's credentials and boom I was in with no problems while my VNC window was still spinning. You may need to reboot the Mac OR see if you can restart the VNC service (good luck, so far the normal commands haven't worked for me) on the Mac.

Hope that helps!


  • 1
    Thanks for the reply, Gerry! I should have clarified that I need a solution for connecting from a Windows PC to the Mac, so Apple's native Screen Sharing app is not an option for me. Commented Nov 9, 2018 at 22:40
  • Cullen, Totally understandable! If that is the case, one option might be to use Google's new ["Remote Desktop" solution:] (chrome.google.com/webstore/detail/chrome-remote-desktop/…) or something like TeamViewer. Sorry I can't be more help than that, I am still looking into solutions myself for both personal and work use. Commented Nov 9, 2018 at 23:14
  • I'm getting this too and need to connect from Windows. I've tried both Tight VNC and the RealVNC viewer but neither work; the same thing happens. Has anyone figured out a fix or workaround?
    – Sam
    Commented Nov 13, 2018 at 3:23

My solution or workaround for this is using TigerVNC and going to Lockscreen when you're done managing Mac remotely. Using this method above, haven't registered "spinning circle" issue.


I have a slight modification to this issue. On using VNC I hit the login screen and cannot type the password. It’s like View Only.

I thought I had it fixed by disabling vnc access and just enabling screen sharing for certain users. Then I used Real VNC configured for Apple Remote Control using machine username and password. It was working great but just quit again.

I even tried killing the login screen with ssh but that did not help. I really don’t understand why I keep hitting the login screen but cannot type a password.


By unchecking this options, I solved the issue.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .