1

I'm on a MacBook Pro (15-inch, 2018) with Mojave 10.14.1. When I connect MBP to a external displays (either via HDMI or via Thunderbolt 2 adapters), the temperature raises sensibly (i.e., CPU temperature lies constantly over 90°) and fans start running fast (i.e., more than 50%) frequently, even if I am doing very simple tasks (e.g., writing in Word with a couple of Chrome tabs open with stackoverflow).

I'm not sure that the problem started with Mojave or if it isn't actually related to the OS version.

I'm wondering if there is a way to limit this annoying overheating as well as fans activity, while using external monitors.

  • You're still within tolerances so technically, it's not overheating. Does your MBP have the discrete GPU or the integrated (Intel) graphics? – Allan Nov 9 '18 at 12:22
  • Well, I'm not an expert of the graphic framework but I can see both Radeon Pro 555X and Intel UHD Graphics 630 in the system tab. In the monitor(s) tab, both seem using Radeon Pro 555X. Unless I'm still in the tolerance zone, I'd really like to reduce this (over)heating phenomenon. :) Is there a way to control it? – floatingpurr Nov 9 '18 at 12:52
  • So, you have one with a discrete GPU. 100° C is (roughly) the limit, so you're well within tolerance. Keep in mind that you need processing to create the frame buffer for the extra display real estate; it's not free. The fans are working as expected. – Allan Nov 9 '18 at 13:07
  • 1
    It's not a problem if it's working within spec. Remember, fans are designed to spin up to keep things cool. – Allan Nov 9 '18 at 13:11
  • 1
    The 2012 was probably the best built (last in it's line) MBP with proper heat dissipation and robust circuitry. This never ending quest to make things razor thin has it's intrinsic costs (heat dissipation being one of them). – Allan Nov 9 '18 at 13:17
1

The higher power GPU in some MacBooks Pro puts out a lot more wattage than the low power GPU.

The reason it gets so hot when hooked up to a monitor, even when you’re just running Word or Safari, is because the display outputs are hardwired to the dedicated GPU - if you’re using an external monitor, the dedicated GPU (graphic card) is in use regardless of how demanding the workload is. This puts more stress on the cooling system, resulting in higher-than-average temperatures ;) Thats the reason. I tried all my 6 Macbook Pro's and all does the same behavior. Switching to the dedicated graphic card and you can't just use the integrated iris.

  • I did not understand the last sentence. Is there a way to switch? – floatingpurr Jan 15 at 0:03
0

The 2018 15" MacBook Pros all have dual-GPUs. The AMD GPU is required to be active when an external screen is connected. There is no way to use the internal (Intel) GPU for external screens.

Fan noise is one of the main nuisances of the MacBook Pros in my opinion. When I get too frustrated, I sometimes use Turbo Boost Switcher, which helps a bit. Volta is a similar App, but does not seem to work with 2018 MacBooks. Both Apps deactivate the CPU's turbo mode, which means less speed, but also less power consumption and less noise.

  • Please don't post identical answers for different questions. See this Meta post for additional details – Allan Mar 19 at 12:45
  • @Allan Just came across this Meta post - confused – n1000 May 2 at 9:19
0

I broke my head for 3 months and finally only one solution worked. Install Fan control app and then increase the fan speed to 5000 RPM. All heating issues gone.. Now whether its external display or heavy applications, Mac is always cool.

  • 1
    What about the noise? : ) – floatingpurr May 2 at 11:44
  • @floatingpurr I use macs fan control with settings set to 55-58C (I use 24" external monitor). Fans are at 2k rpm, a bit higher than by default, but still unnoticeable. After CPU proximity is >58, fans kick in but manage to cool it soon. Unless you're using cpu heavy apps. The only trouble I get is high kernel_task cpu, a task for high temp cpu usecase but this hasn't happened in the past. – edin-m Jun 15 at 15:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .