0

This has to be simple: I can't save DNS servers in Network>(Location)>Advanced>DNS

I add the DNS servers

1.1.1.1

1.0.0.1

2606:4700:4700::1111

2606:4700:4700::1001

save, and then after a sleep, they revert back to what I assume are my ISPs DNS servers.

Any ideas? Is there a way to lock the panel settings?

Sierra Macbook Pro 1014

  • It's overwritten by DHCP. You should put this in your router so it's consistant – Allan Nov 8 '18 at 17:35
  • Ah, that was easy; my mistake. I also have a setting "DNS Relay Configuration: This controls the DHCP Server to assign public DNS." That's enabled; does that make a difference? – BlueDogRanch Nov 8 '18 at 17:57
  • Not so easy,... DHCP Server allots the IP addresses to computers, while DNS server resolves them. You need DHCP Server if you do not want to manually maintain IP Addresses or you have less IP Addresses than number of machines you have, as dynamic DHCP Server will recycle IP Addresses on machines. DHCP does not dictates DNS. – Ruskes Nov 8 '18 at 18:35
  • Minor detail sometimes forgotten. After changing DNS you must Click OK. But then Click Apply to make it permanent. – Ruskes Nov 8 '18 at 18:43
  • Thanks, I was hitting Apply, rebooting the router, the Macbook, etc. And yes, I don't need to mess with DNS Relay. Should I delete this question, as it is more generic and not really Apple related? – BlueDogRanch Nov 8 '18 at 19:22
1

Turned out to be simple - my DSL router had DNS servers configured, and those were overriding the settings in the Network Control Panel due to DHCP being used. DHCP was grabbing the servers from the router and ISP.

So I changed DNS servers in the router, restarted the router and the Macbook, and then could see the 1.1.1.1 and 1.0.0.1 servers in the Advanced>TCP settings; they were grayed out since they were set in the router.

  • Glad you got it sorted out! – Allan Nov 14 '18 at 21:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .