4

I'm running a command-line backup tool (duplicity) as a cron job. But in Mojave, there is a new user data protection feature called "Full Disk Access" (part of the TCC access control framework) that prevents duplicity from accessing certain user-owned files.

How do I whitelist this command-line tool? Since it runs as a cron job, adding Terminal.app to the whitelist won't work. I tried adding the duplicity binary to the whitelist in System Preferences > Security & Privacy > Full Disk Access, but that changed nothing. I also tried running duplicity manually to see if anything would show up in that whitelist, but nothing did.

Edit: the answer to this question is not a solution. I clearly explained that I have already tried whitelisting to no avail.

8
  • I don't think cron jobs use launchd, so I haven't tried whitelisting that. But I could certainly run duplicity using launchd, so I'll try that next.
    – phu
    Nov 7, 2018 at 18:57
  • Misread. Cron is its own process. Try adding that. /usr/sbin/cron? Nov 7, 2018 at 18:57
  • cron isn't "attached" to Terminal the way a standalone command would be, so allowing Terminal won't have any effect. Try launchd as cron has been deprecated.
    – Allan
    Nov 7, 2018 at 22:16
  • I am using a launchd service instead of cron and running in the same issue. It's unclear how to whitelist a specific launchd service into Full Disk Access.
    – tmm1
    Nov 13, 2018 at 1:14
  • 2
    This really is not a duplicate of that thread, since the process for interactive and GUI apps does not work for automated scripts / binaries. If anything, it's closer to a duplicate of this question, but the listed answer for that one is not really an answer.
    – n8henrie
    Nov 20, 2018 at 15:37

0

Browse other questions tagged .