3

I have a serious problem with "Hidden Space" eating up my hard drive.

I'm running High Sierra on a mid-2013 MacBook Air "Core i7" with a 500gb ssd.

The last few weeks, something has to been continually filling my hard drive, as free space has plummeted from 200gb to less than 10gb. No matter how much I delete, my free drive space still hovers around 10gb-15gb. Even when I delete a large amount of files, the size of deleted files doesn't correlate with the amount of free space cleared after I empty my trash.

DaisyDisk found that I've got 135gb of "Hidden Space", 127gb of which is "Still Hidden" and DaisyDisk is "Unable to locate"

enter image description here

I've tried all of the listed items on their support page for this and none of them have solved my problem. I've also contacted their support team but have yet to hear back.

As far as potential solutions I've already tried that haven't worked;

  • I've turned off Time Machine

  • I've deleted my local Time Machine snapshots, which was the culprit for many people with similar problems.

  • I've never used Carbon Copy Cloner, which was another usual suspect for people with this issue, so that's a dead end.

  • I've re-indexed Spotlight, which was a solution for a few people who had this problem in Lion, but doing so didn't do anything for me.

  • Last but not least, I ran Disk Utility in Recovery Mode, and got the following "Snapshot Metadata tree invalid" error:

enter image description here

I tried the solutions listed re; that error as well, all of them having to do with thinning or deleting local snapshots via Terminal, and that hasn't solved anything for me either....

Most of the research I've found suggests that this is an issue with Time Machine's local snapshots, but I've tried all of the listed solutions that worked for other people where that was the problem, and unfortunately none of them have worked for me.

Alternatively, it seems more like my hard drive is continually creating data, until it runs out of space, and then when I try to clear space, it just gets filled with whatever is creating the data. I have no idea how to figure what's doing this or why...

Here's a screenshot of my Activity Monitor re; what's writing to disk; enter image description here

Any help or advice anyone could offer on what else I can do to try and fix this would be greatly appreciated.

Thanks

  • Hi, did you use Activity Monitor to see who is writing to your disk ? – Ruskes Nov 7 '18 at 3:58
  • Hi, I did, and didn't see anything odd jump out. Just updated my post with a screenshot of my latest readout from Activity Monitor – YourGunIsDiggingIntoMyHip Nov 7 '18 at 4:23
  • 1
    You are right, there is nobody writing to your disk in GB range. Did you accidentally activate FileVault ? – Ruskes Nov 7 '18 at 4:50
  • 1
    I agree with your findings, you used the internal drive as Time machine back up, then improperly deleted them and Time machine is still trying to recover/replace. – Ruskes Nov 7 '18 at 5:12
  • To check for it, open a Terminal and list local time machine snapshot by running the command tmutil listlocalsnapshots / – Ruskes Nov 7 '18 at 5:24
3

The system temporary files was causing this so I solved this issue by doing a clean install. That ended up being the only solution that would work.

In case anyone else comes across this problem, I posted more of an update with screenshots here; https://discussions.apple.com/message/34146008#message34146008

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .